BeagleBone Black installation problems

Hi there,

I have got an BeagleBone Black, and have some installation problems, i cannot find solution to.
Machine i am trying to connect to is WindowsXP. After plugging board in for first time system mounts it as mass storage device. After that I go to START.html page and run driver installation (BONE_DRV.exe). Driver installation finishes, and it says that everything is installed and working.
Restart the machine (just to be safe :)).
First: page cannot be found.
Second: in device manager, beaglebobone virtual serial port says ‘Device cannot start (code 10)’

I have tested this on three WindowsXP machines and all give same results.
Might it be faulty BeagleBone board?


I doubt very much it is a faulty board.

Did you look on the support Wiki under the FAQs?

The above URL is on the white card that came in the box.


Yes i did look trought FAQ.

Also i tried BBB with friends machine which also has WinXP, and everything worked.
It seems problem is only on my machine.

Error i get is in device manager:
Linux USB Ethernet/RNDIS Gadget: This device cannot start (Code 10)
Gadget Serial (COM9): This device cannot start (Code 10)

piektdiena, 2013. gada 9. augusts 14:40:33 UTC+3, Gerald rakstīja:

That is a Windows driver issue. Let em see if I can get you some help. Not many people on XP.


By beaglebone virtual serial port what do you mean?
Can you go to:
Control Panel>Hardware & Sound>Device Manager>Ports (COM & LTP)
and tell me if you see anything that says Gadget Serial (COMx), where x is a number.

Oh sorry, I should’ve refreshed the page. I just saw that you checked the Device Manager. Let me look more into the issue and see if I can get it resolved.

Last year, I was getting this same exact error with a different piece of hardware. I found this fix to work and it might work with the problem you’re experiencing. I used method #3. Before you try this, have you tried plugging in the BeagleBone into a different USB HUB?

Also, did you install the correct installer? (i.e. 32 or 64 bit?)

Device cannot start (code 10) is usually related to a corrupted or outdated drivers. But sometimes a simple reboot can solve the issue. These drivers i know for a fact work on Windows 7 x64 so I doubt seriously that they’re outdated.

You can reboot after the driver is installed to see if there was something windows needed to resolve by rebooting. Something all windows user should be used to, and you may have done so already.

If that does not work, then delete the executable you downloaded from Circuitco, and download it again. Making sure you do not have much else going on on that system whilst you do so.

If neither of these possible fixes work, then you’re going to be in for a world of troubleshooting . . . I am not exactly sure which drivers the binary installs but you may need to find the specific driver names, and search those names with “Device cannot start (code 10)” through google to find exactly what the problem is.

As it seems BeagleBone drivers need an Service Pack 3. Previously i had Service Pack 2. Installed update, restarted, plugged in BeagleBone, and gadgets were recognized.

Damn, i have some old computer :wink:

piektdiena, 2013. gada 9. augusts 21:30:48 UTC+3, William Hermans rakstīja: