Beaglebone black not booting correctly

i am trying to boot the beaglebone black with core-image-sato build using yocto project version 4.0.16(kirkstone).

step-1:flashed the linux image to sd card(boot and root partition) successfull.

step-2 : connected the beaglebone serial TX pin to the RX of RS232 to usb cable and also connected ground pins. Power was supplied by connecting the usb mini cable provided by beaglebone black to my PC’s usb port.

step-3 : sudo picocom -b 256000 /dev/ttyUSB0 picocom v3.1

port is : /dev/ttyUSB0

flowcontrol : none

baudrate is : 256000

parity is : none

databits are : 8

stopbits are : 1

escape is : C-a

local echo is : no

noinit is : no

noreset is : no

hangup is : no

nolock is : no

send_cmd is : sz -vv

receive_cmd is : rz -vv -E imap is : omap is : emap is : crcrlf,delbs, logfile is : none initstring : none exit_after is : not set exit is : no

Type [C-a] [C-h] to see available commands Terminal ready

How to solve this? Please help.

why 256000? use 115200… ps i never trust picoterm/mincom…

You can also just use tio:

tio /dev/ttyUSB0


Thank you for your reply. i tried different baud rates including 115200. i also tried tio. But it is giving the same result.