Beaglebone Black not posting to display

Hello BBB community:

Since I received my Beaglebone black, I have been wrestling to get it to work with any display whatsoever (other than the ones thai do work in Best Buy)

I have sent this board into the shop and the hardware is fine, but I just can’t get it to work with any of the displays I’ve connected it to, with one 7" display in particular.

What do I need to do to get this thing to work?

-When connecting to most displays, the 'Bone keeps the display awake, but it won’t actually display anything.

  • my 27" Samsung display worked at first, but now it doesn’t, and only occasionally flashes the desktop for 1-2 frames.
    -EDID Information of my fav. display from serial console:

parse-edid: parse-edid version 2.0.0

parse-edid: EDID checksum passed.

EDID version 1 revision 3

Section “Monitor”

Block type: 2:0 3:fc

Identifier “HDMI”

VendorName “IVM”

ModelName “HDMI”

Block type: 2:0 3:fc

Block type: 2:0 3:fd

HorizSync 29-82

VertRefresh 55-76

Max dot clock (video bandwidth) 140 MHz

Block type: 2:0 3:ff

DPMS capabilities: Active off:yes Suspend:yes Standby:yes

Mode “1280x800” # vfreq 59.810Hz, hfreq 49.702kHz

DotClock 83.500000

HTimings 1280 1352 1480 1680

VTimings 800 803 809 831

Flags “+HSync” “-VSync”


Block type: 2:0 3:fc

Block type: 2:0 3:fd

Block type: 2:0 3:ff


I have reached the end of my rope in this regard and really, really want to get to the fun stuff!

Force override the edid detection by modifying:




If that file doesn't exist, let me know the output of:

cat /etc/dogtag


On my BBB, I hooked up an old 1024x768 VGA monitor to a Cable Matters Active Micro HDMI to VGA Male to Female Adapter (Model 113048-WHITE) and this worked perfectly right out of the box with no need for any adjustments whatsoever. Since I have a remote compilation and debugging toolchain configured and I mostly work on a remote Ubuntu Linux PC, I find that HDMI monitors are usually too large for something that just needs to act as a console.

Oddly enough, forcing that resolution worked for my 1080p monitor, but not the 1024X768 one :confused:
Any ideas on how to get the 1024 one working? It’s a $60 7-incher I bought just got the board, and it’d be a shame if it sat somewhere collecting dust!

The output for
cat /etc/dogtag

is BeagleBone Debian Image 2014-05-14