Beaglebone Black on MacOSX 12.1

I just purchased the new macbook pro with macOSX 12.1 and I cannot login to my beaglebone black wireless on chrome. I believe it is because the mac drivers are for older versions. Does anyone know if there are new drivers and how to install them or if there is a way around this.
Thank you

Hi @Jeremy_Bogacz ,

Is this over the usb-otg connector of the BeagleBone Black Wireless?

We pushed a patch for the usb-gadget in the default images on Apr 9, 2020 ( boot: Update USB CDC Ethernet gadget to use NCM · RobertCNelson/boot-scripts@b61125c · GitHub )

What version of the OS are you running?

This will help dump out the details.

sudo /opt/scripts/tools/version.sh

Regards,

Hi @RobertCNelson,
Yes its over the USB-otg connector. I am running Debian Buster IOT 10.3 on the beaglebone.

hi @Jeremy_Bogacz , what’s the date on that build?

debian@BeagleBone:~$ cat /etc/dogtag 
BeagleBoard.org Debian Bullseye Xfce Image 2022-01-18

Regards,

Hi @RobertCNelson,
The date is 4/6/2020. Its the Buster IOT flasher image on the beaglebone website under latest images.

So the fix was merged 3 days later…

From:

/opt/scripts/
git pull

and reboot…

or grab the latest snapshot:

https://forum.beagleboard.org/tag/bbbio_debian

Regards,

Hi @RobertCNelson,
So i have updated to debian 10.11 buster IOT image and I can now ssh into the beaglebone on the mac terminal. However I still cannot connect to the beaglebone using the ip address in chrome.

192.168.7.2 = RNDIS (Windows - Linux)
192.168.6.2 = cdc-ncm (MacOSX - Linux)

So use, 192.168.6.2 on mac in the webbrowser.

Regards,

I tried using 192.168.6.2 and I also tried to go directly to cloud9 using 192.168.6.2:3000 and both just time out after a while. In the network section in system preferences it says the beaglebone has a self-assigned ip and the ip address is 169.254.48.119
Screen Shot 2022-01-19 at 11.28.25 AM

Waiting for updates, this macmini is one of the slowest… (Big Sur 11.6.x)

Browser

en5: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
	options=400<CHANNEL_IO>
	ether 80:f5:b5:aa:4f:bd 
	inet6 fe80::1c1d:7b79:486c:183d%en5 prefixlen 64 secured scopeid 0xf 
	inet 192.168.6.1 netmask 0xffffff00 broadcast 192.168.6.255
	nd6 options=201<PERFORMNUD,DAD>
	media: autoselect (100baseTX <full-duplex>)
	status: active

Network

Edit, this took awhile, but MacOS 12.1:

macos_12_1

Regards,

Hi @RobertCNelson,
I still cannot connect to the beaglebone on safari using the IP address. In my network settings it still says self-assigned IP with a yellow marker. Could it possibly be because I am using a USBC-USB adapter to plug in the beaglebone.
Thank you

any chance do you amazon part number for that? My MacMini doesn’t have type-c, but my windows work laptop does… Wonder if it’s the cable… or yeah… I’ve never tried a type-c → into a Black or Black Wireless…

Regards,

Its the usbc to usb adapter from apple. The ASIN on amazon is ‎B00VU2OID2 and the model number is ‎MJ1M2AM/A

Perfect ordered!!! Will test next week…

I like this statement…

Screenshot

Regards,

Just an update, got that adapter…

It’s working fine on my Windows 10 laptop… (my MacMini does not have a type-c port…)

Regards,

Okay. Not sure why it’s not working on my laptop. Thank you for everything, I really appreciate it. I am able to ssh into the beaglebone on the built in terminal so I can still work on it.
Thank you,
Jeremy Bogacz