Beaglebone black php.ini missing

Am using beaglebone along with Armstrong linux which is in flash memory ,i installed php and lighttpd as described in the below link

I didnt disable the services but i chnaged the port of lighttpd to 8080 in conf file.

php.ini file is missing in my filesystem…

When trying to open index.php file am getting 500 Internel server error

in log file it says

2000-01-01 01:43:38: (mod_access.c.135) -- mod_access_uri_handler called 
2000-01-01 01:43:38: (mod_fastcgi.c.3570) all handlers for /index.php? on .php are down. 
2000-01-01 01:43:38: (response.c.731) -- subrequest finished 
2000-01-01 01:43:40: (mod_fastcgi.c.2829) fcgi-server re-enabled: unix:/tmp/php-fastcgi.socket

Hi ganesh,

Did you get solution of : why php.ini file is not on Angstrom file system? I want to enable ssl support for php and I found from many blogs that it can be doen with some changes in php.ini file.


I just set up nginx on my BBB to serve php pages. I also didn’t have a php.ini file. So I copied one over from my mac. You can probably find a default one online. But I was able to set up ssl without it. Goodluck.