BeagleBone Black powers up with only D2 and D3 blue leds on permanently and halts

I purchased the IoT DevKit and have been working with it no problem for the past week. Got the cell cape working right off the bat and have been working on getting the GrooveBoard2 cape and some sensors working.

Today, I went to update the image, followed the usual instructions and copied to a new SIM and boot from it. After pressing the BOOT/RESTART button and powering the device up, only the outer two blue led lights light up (I think it is D2 and D3). I tried pressing the power button but that did nothing. Since there was no way to power it down, I pressed the held the power button to do a hard reset. I removed and inserted the power and when it started up, it was still the same state. Finally, I did another hard reset to power down, removed the 5V power, and then removed the SIM and rebooted trying to get back to the original eMMC boot image, but unfortunately it is in the same state, only D2 and D3 led lights are on permanently.

Also, it is not mounting as a tty device on my Mac so there is no way to even use screen, just the solid blue lights. :frowning:

I have worked with BeagleBone Whites and Greens, even pulled the power on them by accident on a couple of occasions. I am reading up that the Black seems to be more fragile - did I manage to fry it?