Beaglebone Black Rebooting Several Times Every Day

Got my first BBB last week, installed latest Debian. USB Hot Plug was completely hosed in Kernel 3.8 so I upgraded to 3.16 (latest non-rc version). Currently running CUPS print services (including Airprint) and weewx. It appears that the BBB is rebooting three or four times between 10pm and 1am, this has happened the last two days. I discovered it because weewx was going into an ftp loop because the system clock time was getting whacked (it is time/date sensitive to process weather data). Nothing in the log files unusual. Powered with a 5v 2a supply. Ethernet cable attached and external USB Hub (has external power but not used) with printer (turned off) and Weather Data Logger attached (has it’s own power).

Before I start experimenting with removing USB Hub, plugging in just Weather Data Logger, etc. thought I’d check here first.

Hi Greg -

Are you booting from your SD Card or have it inserted?


If you have a serial interface, I suggest turn on logging and post the results here.

When the SD card is inserted it automatically boots from there. Have a look if there is a file called 'eMMC-flasher.txt' in the root of your SD card it will start flashing on each reboot and reboots again.

If that doesn't solve it I would suggest overwrite the following commands with a bash script that logs the output of a PSTREE to a logfile.
- halt
- shutdown
- reboot

That will allow you to see what is triggering it.


I am booting straight from eMMC that I flashed, no uSD and no serial interface. I have disabled cups and weewx from starting and removed the external USB HUB and changed the power supply to another 5v 2a. I can tell it has rebooted by looking at syslog for ntpdate ‘step time server’ events. My syslog resets daily at 6am, so looking at syslog1 it rebooted 10 times in last 24hrs. This is not a shutdown or reboot it is a system reset. Since I have removed all external attachments and USB is idle, I have to assume it’s either a board hardware issue or the 3.16 kernel as reboot times are random and I don’t have anything in cron.hourly. In 3.16 leds have been renamed to heartbeat, mmc0, usr2, usr3. I have heartbeat turned off. PSTREE not installed and apparently not a .deb dist either.

I have downgraded the kernel from 3.16.0-bone2 to 3.15.10-bone8 and so far no reboots in the last 3 hours. If I get a full 24 hr cycle without reboots, I’ll blame it on 3.16.0 and try to re-attach ext USB HUB, weather data logger, printer, and enable cups and weewx and see how far I get this time.

Thanks for the report, please let us know how v3.15.x react's too..
I'm currently chasing a few other issues with v3.16.x (acpi isn't

btw, if you want something that's going to be a lot more
supported/tested down the road.

sudo apt-get update
sudo apt-get install linux-image-3.14.17-ti-r15

We are preping for a big transition.


Maybe check your power plug. There are many plugs that fit the socket on a BBB, but some do not provide a reliable connection. The one you should be using is having a spring-loaded central socket - see picture


Plug on both power supplies is correct size and fit nice and snug.

Instead of rebooting 10 to 12 times it only rebooted 3 times in syslog, at 6:24pm and 11:06pm and 12:03am. Still random reboots though with nothing in USB and sitting idle. Not so sure it’s a kernel issue at this point, could be hardware related but willing to try another kernel to see what happens.

power the board by USB, remove the wall adapter and test again. This issue was described long ago but there was the kernel 3.2. The issue disappeared with the 3.8

I just downgraded to 3.14.17-bone8 so let’s see how that works. Will watch syslog for 24 hrs and see if it reboots.

Thanks for the suggestion, if I get reboots with 3.14.17 I’ll try the usb power and if that doesn’t work I’ll go back to 3.8 although I had USB hot plug issues with that version.

BBB ran for 6 hours and just rebooted at 12:30pm so I now have it powered through the USB port with a 5v1a power supply instead of through the main power plug. If this reboots my last attempt will be to downgrade back to 3.8 and if it still reboots I’ll have to send it back. It’s an element14 purchased from an online vendor.

Well it just ran for about 15 minutes and rebooted using USB power, so I’m going to reflash eMMC with original distro and try that then return if it reboots again. Will get a BBB from Adafruit although the vendor has offered to send another element14 replacement.

Greg, please give this image a shot.

It includes all the "3.8" kernel fixes since the May release came out..


Hi Robert, I reflashed the original distro and it ran for about a half hour and rebooted so I have determined it is a hardware issue, (probably a grounding problem according to the vendor so perhaps there is a QC issue at element14) so I have returned the element14 BBB to the vendor for a refund and ordered a CircuitCo BBB from Adafruit. Will arrive Monday so will have it up and running on Tuesday. I plan to upgrade the kernel to 3.14.17-bone8 which is close to what you recommended for stability and long term support. I can give the 2014-09-13 image a try before kernel upgrade if you need me to test but it will be on a new BBB and not the ‘problem child’. Thanks for all you hard work, makes maintaining a BBB pretty painless.

Robert, I just looked at the kernel in this image (3.8.13-bone64) and that was the first image I flashed after receiving the BBB. I had USB hot plug issues with that kernel version so I upgraded to 3.16.0. It would not recognize an external USB Hub plugged in after startup, only when plugged in at power up and would not recognize any USB devices hot plugged into the Hub. Not a problem with 3.14, 3.15, 3.16 when I was testing.

Update: I received my new BBB - a CurcuitCo version from Adafruit on Tuesday. On Wednesday I got it set up almost identical to the other one I sent back. It has 3.14.17-bone8 kernel. It rebooted/reset on Thursday at 2:15am and the physical ethernet port was down, so I had to connect via the USB port to look at syslog and see what happened. There is no entry for reboot or shutdown so it looks like a complete reset is taking place. Logs show ethernet port not coming up and dhcpclient says network unreachable

I did a power down and restart and it ran fine until Friday morning and reset twice at 7:35am and almost immediately again at 7:50am. Both times it looks like during the boot sequence that network services are starting after ntpd as ntpd can’t resolve hosts. dhcpclient can’t find the network and retries about a half dozen times then the ethernet port finally comes up and it’s back online. This is physically plugged into the same hub that my RasPi is plugged into (and has been running non-stop for over two weeks now, no issues with it whatsoever).

I certainly can’t use this BBB as a print and weather data server with it behaving this way so I’ll keep these running on the RasPi until I can figure out why this is resetting constantly. Using a 5v 2a power supply and I’ve tried two different ones with the other BBB so I don’t think it’s a PS issue, but that doesn’t leave much else to blame for random resets.

Ideas and suggestions welcome.

I know it's a little intrussive, but can you do me a favor... Have
another machine log the debug serial port... Then we can see what's
going on..

BTW, that "3.14.x" isn't being worked on... If you have a new "testnig" image:

sudo apt-get update
sudo apt-get install linux-image-3.14.17-ti-r19