Beaglebone black rev C not booting and output "CCC" on serial port

I have a beaglebone-black revC that is not booting from sd-card (tried with reset and power buttong) and output is “CCC” on serial port.
The sd-card is correctly partioned and has tried in all possible combination.
There is no OS in flash and neither u-boot.
Is there any way to reflash an OS and u-boot to flash so that the beaglebone can be recovered to its original state.

Thanks in advance.

This means the AM335x can not find u-boot in any of the proper locations.

Grab something like: AM335x 11.7 2023-09-02 4GB microSD IoT - BeagleBoard


In fact by multiple attempts:
I got this message on terminal:
"U-Boot SPL 2016.03-00001-gd12d09f (Mar 17 2016 - 16:16:15)
Trying to boot from MMC
Card did not respond to voltage select!
spl: mmc init failed with error: -17
SPL: failed to boot from all boot devices

ERROR ### Please RESET the board ###"


That’s really old…

Grab this flasher to overwrite teh eMMC: AM335x 11.7 2023-09-02 4GB eMMC IoT Flasher - BeagleBoard it’ll include u-boot v2022.04.


make sure you have a good 5v supply, those 5 volt USB wall warts can be problematic.
just saying from experience.

I can flash this using SDCARD?
I am concerned about the message saying “card did not respond to voltage select”
Does it says the sdcard reader is not working?

I will try with 5V 2Amp adaptor thanks.

I am trying to create a new image ( AM335x 11.7 2023-09-02 4GB eMMC IoT Flasher - BeagleBoard) on SDCARD.

For any image when I try to flash it either on windows (balena/win32diskimager) on linux (dd), they create only rootfs partition and in rootfs there is a boot folder contains all boot partition file. I think it is normal that the beaglebone is not booting.

Then, I tried to partion the card correctly using fdisk and copied manually rootfs and boot files with correct bootflag. But beaglebone is not booting too.

I am not getting what I am missing, could you please suggest me which tutorial to follow and why all .img.xz files are like this?

Thanks in advance.


Unless your SDCARD is helplessly broken, Balena Etcher will rewrite the partition table,
so I have a hard time believing that you’re doing something wrong while making the card.

However, I can’t see if you have tried pushing the USER button while turning on your Beagle.

Can you try that and see if it boots from the SD instead of the eMMC?

I am pushing the S2 button before even the board is power-in and releasing once it is powered-in so that beaglebone boot from SD-card but no success.

Ok. Thank you for clearing that up.

Almost afraid to ask, but ofc. you have also tried to just power the board up w/o pressing S2, yes?

I wonder how your Beagle could just suddenly decide to ignore your SD card entirely,
but it sure does feel like it.

What kind and size of SD card are you using?
Mine is a “run-of-the-mill” Kingston SDHC, Class 10, 4GB, so not one of those new fancy ones.

The file from that link works fine for me. Downloaded and flashed to 16Gb SD Card.

I suggest trying a different SD Card.
Also did you download the checksum to check the the image file ?
Although it sounds like the image was ok as you could see the rootfs on the sd card.

There should only be the 1 partition. u-boot is perfectly capable of reading ext4 partitions to read the files in /boot

You can just partition an sd card and copy files over. The binary u-boot file that is initially loaded is not an actual file in a partition. Using balena/dd or whatever you prefer is the correct way to make an image. Although for dd you must decompress the downloaded file first.

Many thanks for your comments.
I am using micro sd 16gb Sandisk SDHC I cards, I two of same type and yes I had a doubt on the card so I tried a different mark 8gb… But it is very strange to understand.
I have another doubt, in the boot folder may be there is not correct dtb or MLO that may require to boot so I need to find correct one from inside folder and try to copy in boot folder directly in case it is unable to find.

Few days before, when I succeed to have few message on console after multiple trial with S2 key, it shown me that “Card did not respond to voltage select!”.

At last, I guess my sdcard reader on beaglebone is dead.
I have an empty emmc, USB bootable is not possible it seems.
I will give some more try with SDcard and then see.

If the eMMC is blank, you do not need to hold down the S2 button.
It just swaps he order of boot, however if one medium is blank the other device is tried.

The actual u-boot binary is stored at the beginning of the sd-card somewhere. Can’t remember where exactly. That alone should give you some output on the serial port, even if the root partition is wiped.

If I use dd to write 10Mb of 0 to the rootfs parition on the sd-card, u-boot still loads and runs, although it doesn’t boot because there is no rootfs.

If you are not getting that and you have tried several sd cards I would firstly suspect a damaged sd card slot. The fact that you get CCC on the console indicates the processor and initial ROM boot code is running.

1 Like

That is actually a very good point. When you turn your Beagle upside down, can you see the 8 small “pickup-like” pins that touch the gold pads on the SD move ever so slightly as you push in the card?

If you have any Iso propyl alcohol, try using that on a cotton-swab, clean the gold pads on the SD and then insert the card into the Beagle a few times. It could be something as simple as a bad contact if you don’t have something like an obvious bent pin.

You shouldn’t try and clean the “pickup pins” directly; they are way too fragile on their own.

Do you have a ttl adapter to connect and see the exact steps in the boot process.
If you do and see the kernel panic because it cannot find the boot partition you will have to wipe the emmc. More than likely your board has an older version of u-boot and its not passing the proper parameters.

It shows an older u-boot from 2016, the current version is 2024. Until the u-boot is correct for the image it will not boot.

With the ttl adapter connected post your boot up, we need to see where it hangs.

Also, the best tool for SD card burning is the raspberry pi imager.

Thanks for your input, it made me to think playing around and I started getting the message on serial port.

By doing that I figured out the problem is not contact with gold pad and sdcard pins.
My sdcard reader slot is damaged from otherside of seriography “P10” all for pins are desoldered and its mass pin is broken.

So the board boots completelely and come to login if I keep holding it by hand. So I need to rectify this.

Thanks again.

I agree with you, once I resolve my SDCARD slot problem I will upgrade the u-boot.
Thanks for your comment.

Thanks for details. Appreciate your comments.