Beaglebone black socket bonescript And socket io question

I want to know if when i want show the state of one digital or analog pin, should i use the socket io.
I want to understand hoy to get a valué of one variable from bonescript in a html page.


I found this example via google, I think it will help you.

I have tried to run the examples but I get one message in the cloud9 that said that I don´t have the socket io installed. Then I have tried to install the socket io using the SSH and I got the error message as follow :

ERROR : getaddrinfo ENOTFOUND.

Please your help because I don´t know how to install the socket io and I believe that while I don´t install it i won´t be able to read an external signal and show the information in the html page.


Dear andrew

Thank You very much for your help.

I have tried to run the example And I got an error in the cloud 9 that said that I don’t have the socket io installed.

After that, I tried to install the socket io using the console And Now I have the error Message

ERROR : getaddrinfo ENOTFOUND.

If You have some advice I really appreciate your help.

Thanks again.


I don’t have any idea what that error message means.
I have recently flashed my BBB with the 9/4 image & had to npm install socketio - I didn’t get any errors with my project/cloud9, which is based heavily off of the example I posted. Sorry I can’t be of more help.

Dear andrew

I’m really confunsed. If I’m doing a page html in the cloud 9 And I want show the state of A digital or analog input wíth this html page using the HDMI output of the BBB, should I use the socket IO or should I to try to transfer the state of the data from a node.js file wíth some javascript code?

I want to be sure that socket io is for use on server/client applications or if It’s necesary for transfer variables like I want to do.

Again, I really appreciate your advice…

Best regards


There is another guy doing the same thing from this website:

I would recommend installing the socketio by typing “npm install” within the /var/lib/cloud9/ directory.

Lets us know if you get either example working.