BeagleBone Black USB Host hot plugging issues

It’s a long story so please bare with me.

Bought the BeagleBone Black somewhere in October.

The USB host port worked fine. No issues with cold plugging and no issues with
hot plugging.

I screwed something else up and had to reinstall the OS.

Got the ‘latest image’ from, which dated
back to june 20th. It seemed reasonable that this was in fact the latest image.

Succesfully flashed the eMMC using the angstrom image from june the 20th.

Issues arose with the USB host port. No issues with cold plugging. However,
hot plugging no longer worked. No error messages were sent to the journalctl when
hot plugging, it just didn’t seem to detect it at all. When a coldplugged USB
device was removed journalctl reported messages like:
usb 1-1: device descriptor read/64, error -19
hub 1-0:1.0: unable to enumerate USB device o… 1
hub 1-0:1.0: port 1 enable change, status 00000101
After that once again no activity when hotplugging the USB device.

I thought that this was because I was now using a newer image than the image
that was installed on the eMMC when I received my BeagleBone Black.

I found a patch on github that basically FIXED an issue with hot plugging
devices in the BeagleBone Black. It indicated that I probably was now using
an older image than the one my BeagleBone Black was shipped with.

After a chat with jkridner it became known that the latter was true. The ‘latest
images’ were in fact not, the latest images. He updated the image to the actual
latest image (of October the 4th).

I then flashed the eMMC with the image of October the 4th, only to find out
that I was still having issues with hot plugging USB devices.

It’s not a power issue, I’m using an external power source and error -71 would’ve
indicated a power issue but I’m getting an error -19. I haven’t been able to
find any information about error -19 online.

I’m completly confused and lost right now and I hope someone here can
at least point me in the right direction.

Thanks in advance for the time you’ve invested in helping me!

Nevermind I now know for sure it’s the USB device that is causing the issue.
It’s a storage device, and it works fine when hot plugging into my laptop.

I plugged another USB storage device into the BeagleBone Black and that worked fine.
So the USB device that fails must’ve become somewhat broken somehow. Not broken
enough that my laptop doesn’t accept it anymore but broken enough that the BeagleBone
Black doesn’t accept it.

This post can be removed.