Beaglebone black using Port 8 Pin 3 as a GPIO pin

I am also getting the similar error. Did you solved this. Please share if you have

Thanks

Edit the device tree loaded at boot time and disable the eMMC by setting:

  status = "disabled";

...for the eMMC, as described here:

https://github.com/modmaker/BeBoPr/wiki/BeBoPr-goes-Black

Once you do this, other than the initial reading of the boot loader
from the eMMC (by the AM335x ROM code), there will be no access of the
eMMC by the kernel and you will be able to remap that pin.

I am also getting the similar error. Did you solved this. Please
share if you have

Thanks

Gday all

I am currently attempting to move a project from the beaglebone
white to the new beagle bone black and hit have hit a road
block.

Currently our cape uses the P8 pins 3, which is used by the eMMC,
I need to work out of there is a way to disable this device so I
can remap this pin.

I have managed to get the device tree stuff working perfectly
thanks to the work of others around uart pin muxing but a
solution to this has alluded me.

I am running the following image
http://rcn-ee.net/deb/rootfs/raring/ubuntu-13.04-console-armhf-2013-05-18.tar.xz

I have applied the patches provided by http://pignology.net/blackdts.tgz

Any hints or tips would be amazing, at the moment when i try and
load my very crude test file.
https://gist.github.com/wolfeidau/5617929 I get the following
error.

[ 79.888940] bone-capemgr bone_capemgr.8: part_number
'uart2pinmux', version 'N/A' [ 79.889118] bone-capemgr
bone_capemgr.8: slot #6: generic override [ 79.889169]
bone-capemgr bone_capemgr.8: bone: Using override eeprom data at
slot 6 [ 79.889222] bone-capemgr bone_capemgr.8: slot #6:
'Override Board Name,00A0,Override Manuf,uart2pinmux' [
79.889507] bone-capemgr bone_capemgr.8: slot #6: Requesting part
number/version based 'uart2pinmux-00A0.dtbo [ 79.889561]
bone-capemgr bone_capemgr.8: slot #6: Requesting firmware
'uart2pinmux-00A0.dtbo' for board-name 'Override Board Name',
version '00A0' [ 79.902579] bone-capemgr bone_capemgr.8: slot
#6: dtbo 'uart2pinmux-00A0.dtbo' loaded; converting to live tree
[ 79.902994] bone-capemgr bone_capemgr.8: slot #6: #2 overlays
[ 79.908739] pinctrl-single 44e10800.pinmux: pin 44e10818
already requested by mmc.10; cannot claim for helper.14 [
79.919714] pinctrl-single 44e10800.pinmux: pin-6 (helper.14)
status -22 [ 79.926884] pinctrl-single 44e10800.pinmux: could
not request pin 6 on device pinctrl-single [ 79.935866]
bone-pinmux-helper helper.14: Failed to select default state [
79.966663] bone-pinmux-helper: probe of helper.14 failed with
error -22 [ 79.967002] bone-capemgr bone_capemgr.8: slot #6:
Applied #2 overlays.

I am currently booted of the miniSD running the aforementioned
image.

Thanks

- --
Charles Steinkuehler
charles@steinkuehler.net