BeagleBone Black Webcam

Hello all,

Sorry for the long message, but I want to include all the details I thought were necessary.

I am extremely new to Linux, but I have recently purchased a Beaglebone Black, and I am trying to set up a webcam server on it. I have tried to follow several tutorials online, but none of them have worked, because I cannot get the webcam to work. I have a Logitech C525 HD webcam, which is on the list of supported webcams ( I am running Debian 7 (wheezy) with Linux Kernel 3.8.13-bone37. I have installed LXDE so I have a desktop, and VLC to check the functionality of the webcam. I am booting off of a 16GB micro SD card. The Beaglebone is being powered by 5 volts via the barrel connector and a power supply. The webcam, keyboard, and mouse are connected to a powered USB hub. The lsusb command returns “Bus 001 Device 003: ID 0460:0826 Logitech Inc” whenever I have the webcam plugged in; so I know the camera is being recognized. However, when I run the ls /dev/video* command, I get “ls: cannot access /dev/video*: No such file or directory”. This seems to be what VLC is looking for, so it doesn’t see the webcam. When I run the dmesg|tail command, none of the entries mentioned anything about video or the UVC driver. I ran sudo modprobe –v uvcvideo, then I ran the dmesg|tail command again, and this time I got 2 additional lines 1) usbcore registered new interface driver uvcvideo 2) USB video class driver. I apparently have to enable the uvc driver after each restart, but I still don’t get anything when from the ls /dev/video* command.

I should also mention that this is my current configuration, but I have also tried this with Ubuntu 12 and Ubuntu 13 (both installed with instructions from ( I get the same results no matter what I do. I have also tried several other webcams that were not on the list of supported webcams, with the same results. I know the webcams work with Linux because I have tried them on an old laptop that is running Mint 12, and they worked just fine.

Since the webcams work in Mint, and many other people have been able to get them working on the Beaglebone, I am obviously missing something, but I don’t know where to go from here. Any help would be greatly appreciated.


There are known usb issues with the 3.8 kernel.. Please test with "either"
Ubuntu/Debian base microSD:


cd /opt/scripts/
git pull
./tools/ --beta-kernel

To pull in a v3.13.x based kernel..


If you’re using Roberts instructions for compiling the kernel, did you poke around in menuconfig to see if the cam needed a specific driver compiled in ? Also I would recommend if this is an option that you actually compile the driver module into the kernel ( <*> ) instead of as a module ( [M] ).

Passed this, sorry I have no further advice to add.

I am facing same issues Williams, I am a newbie so can you tell me how to compile the driver module into the kernel and as a module. The webcam I am trying to interface is based on gspca_ov519.

I used

opkg install kernel-module-gspca-ov519

and found that it was already present on the root but I am not able to see the /dev/video*.

Thanks for your reply in advance.

hey OP good luck with your project! i am looking to do something similar too so will be following this thread closely.

in regards to the Logitech C525 HD webcam, are you expecting the embedded mic/audio data to be captured as well as video?

does anyone have any thoughts if that can be done or would audio and video need to be separated out somehow.
hope the question fits in here.

Thank you Robert for your reply. It has taken me a while to get back to this. I tried your suggestion, but I still get the same result. I now how version 3.13, but I still do not see anything when I run the ls /dev/video* command. I have also re-enabled the uvcvideo driver; but that did not help either.

Try this tutorial.