BeagleBone Black Wireless connman doesn't exist

Hello everyone,

I have flashed my BeagleBone Black Wireless to the latest IoT image, but the image doesn’t contain connman package and other packages too. Is there any solution to enable wifi, at the moment ifconfig doesn’t show wlan0.

It should have systemd-networkd

In Debian Bullseye (11.x) we moved from Connman → systemd-networkd + wpa_supplicant

I’ve listed hints using wpa_cli and wpa_supplicant-wlan0.conf here: Debian 11.x (Bullseye) - Monthly Snapshot - 2023-09-02


I tried instructions and my wpa_supplement.conf looks like that:
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev


But I have following error, when I run wpa_cli -i wlan0 reconfigure:
Failed to connect to non-global ctrl_ifname: wlan0 error: No such file or directory

wlan0 interface is “off” and its setup is “configuring”

Same issue here, please help

Hello @Srujan_Sriram ,

If you are using Bullseye, go to this file to enter in your credentials: /etc/wpa_supplicant/wpa_suppliment-wlan0.conf .

If you are using Bookworm, I think there is another file to test but there are particular commands one can use:

Using Bullseye. And I had updated wpa_supplicant-wlan0.conf with my credentials, but I don’t think that is the problem. To begin with does Beaglebone Black Rev C3 even have Wifi ?

This is my image:
AM335x 11.7 2023-09-02 4GB microSD IoT
](AM335x 11.7 2023-09-02 4GB microSD IoT - BeagleBoard)

Hello @Srujan_Sriram ,

No. It only has Ethernet. The BeagleBone Black Wireless, sort of in the name, is the BBB w/ WiFi.

There is also some other boards like the BBGW, BBGG, and BBAI that have WiFi access to ssh among other things.


P.S. The newer boards like the BBAI-64 has M.2 key access for WiFi, the BeagleV-Ahead has WiFi, and the Play has WiFI also. Now, I know nothing about the Play for now but hopefully one day I can get my hands on one to test the speed and connectivity.