BeagleBone Black Wireless with UBUNTU 16.04 Xenial Wi-Fi not working



UPDATE: After trying several suggestions, I have ended up in the following situation; I’ve set up an ad-hoc connection (I chose “Shared to other computers” method in the IPv4 setting tab) on my UBUNTU laptop (device A).
Then, I created a connection on my second UBUNTU laptop (device B) with ad-hoc DHCP(auto) and its ESSID was set as the ESSID of the initial connection created on device A.
The connection between the two devices worked smoothly.
After that I tried to achieve the same kind of connection, but this time between the device A and a BeagleBoneBlack Wireless (flashed with UBUNTU 16.04 Xenial console). Here’s the edited /etc/network/interfaces file for the wlan0 connection:
However, this time a connection was not established.
ifconfig for the BBBW:
I am also posting the results of the wireless-info script:
Any advice?

UPDATE: I ran a diagnostics script for Beagleboards named Here are the results:…on_sh.txt?dl=0
In line 10 it shows a warning about a firmware package not having been installed.

Ubuntu doesn't have that specific package, instead they install the
needed firmware thru the "linux-firmware" package, which is installed.

The main problem with ubuntu 16.04, the default version of connman is
too old to be useful. (1.21)

When i back ported a newer version of connman, most users complained
about it, so i removed it.

So for ubuntu 16.04, it's up to "YOU" to configure wifi, thru
wpa-supplicant and friends. I'm not wasting personal time on 16.04.

For ubuntu 18.04, ubuntu has a much newer version of connman that works well.


I know this comes later than expected, but after some experimentation, the following steps solved all of my problems:

  1. I installed the March ubuntu 16.04 image file instead of the February one, since it solved all problems with cape managers.

  2. I tried downloading this file:
    sudo wget

as advised by this forum:, and replacing the existing file at:

  1. I set up a connection encrypted with WPA/WPA2 password with the following basic directions:

To create a wi-fi interface connection between BBBW and your PC do the following at your PC, using ubuntu’s GUI program Network Connections:

  • Add the new wi-fi connection, using the hotSpotPC as SSID. This SSID should be the same as the one at the BBBW interfaces file, see below.
  • At the Wi-Fi tab choose Hotspot Mode.
  • At the Wi-Fi Secutiry tab choose WPA/WPA2 Personal and a password.
  • At IPv4 Settings tab choose the Shared to other computers Method.

To create a wi-fi interface connection between BBBW and your PC do the following at BBBW, using the serial console and the minicom program:

  • Edit the interfaces file in BBBW using:

    sudo nano /etc/network/interfaces

  • Comment the lines:

auto eth0

iface eth0 inet dhcp


  • Add the following lines:

auto wlan0 iface wlan0 inet dhcp wpa-ssid hotSpotPC wpa-psk useTheDefaultPassword

  1. Whenever I start up my hotSpotPC Host, I disconnect my ethernet connection, since for some reason the ethernet connection prevents the BBBW from establishing a wireless connection. However after the connection has been established, I can safely connect the ethernet and have internet access on my BBBW.