Beaglebone Black won't boot from Micro SD, all LEDs remain lit

My beagleboard Black was working fine till yesterday … Im not sure why … But it initially stopped opening up the emmc and the emmc access light blinks for a little while then stopps .
The heartbeat LED was still working but after a while it switched off and no when i plug in the usb or and external supply it doesnt switch on . I tried pressing the power button but the
power LED just blinks once every time i press the power button . Can someone help me out .

Try reflashing the eMMC. and in the future, use the power button to shut the board down instead of pulling power.


Hi all
I am a newbie to beagle bone black. My BBB is not booting. When powerd with the barrel connector, only the power led is glowing.Any of the USR leds does not glow. Tried to reflash the eMMC, but no change. Also the board does not power up with the usb cable. Any suggestions??

I would make sure you flash it correctly per the instructions and run it from the DC jack.

Depending on what you have plugged in and how good the USB power source is, it may not power the board.


Thank you Gearald, for you timely reply.I am using a 5V Power bank to power the board. But I think that the power supply may not be the problem because the same does occur when I connect it via my laptop. Also I forgot to mention that the board heats up unusually. It is worthwhile to mention that I have another BBB which works on the same power bank without issues.

And yes, the instructions were perfectly followed for flashing. I think this might not be wrong because i have already flashed my other BBB three or four times

OK. Information is helpful. It helps people help you when they are crafting a response. Nice to know you have another board that works.

I would say based on the added sentences, unless you have more to tell, that the other board, the one that does not work and heats up, is damaged. I suggest you go to this link: item #15 in the menu.


I have one more question to ask. Please bear up with me. In the link that you have sent, I find that RMA can be filed only if the stock has been purchased from an authorized distributor. I am from India. Here we have three authorized distributors and all of them were out of stock. As we are hurrying up with our final year BE project we had to buy one from another online shop. Would my application for an RMA be considered?

In that case, you would need to send it back to that distributor for replacement or repair.


Gerald, I seem to be having a problem booting any image from a uSD. I originally tried putting other distros on the bbb when purchased back in Dec. Then I decided to just flash the eMMC with Angstrom, which seems to work fine.

Now, however, I am incorporating the radium camera cape into a project and I cannot seem to boot with their modified Angstrom image, which apparently is required to be used via uSD because the cape interferes with the eMMC.

Trying to boot from this and any other image produces user LED activity for about 3-5 minutes, and appears to be booting from uSD based on lights. Then suddenly without warning, the LED activity stops and the 2 middle user LEDs stay lit solid, along with the pwr light. I know this is related to power failure in other cases, but wondering if that is the same issue here? I have been using a combination of bench top and wall wart pwr supplies, all rated at 5V/2A.

Any thoughts?

well, the camera cape and radium board’s modified image is working. I went from a class 2 to a class 4 uSD. No idea if that was the fix. I also re-downloaded the image and went thru trying to get it booted again. I disconnected everything except an HDMI cord and the 5V 2.5 DC barrel plug, and now it boots without too much trouble.