BeagleBone Black won't boot from SD card

I have recently bought a BeagleBone Black, I have flashed an 8 GB class 10 micro SD card with the latest image file and inserted it into the Board. When I connect the board to a PC it boots up and connects via Putty, when I press and hold S2, then press and release S3 and then release S2 the board turns off and does not reboot, all the lights go off including the power and only restarts when I press S3 and uses the eMMC image.

What is wrong?



Is your SD card correctly programmed with the image?

Is there an issue with your SD card? Do you have another one to try?

Did you grab the right image file for the right product?

Are you able to stick that SD card containing the beaglebone image into a Linux PC via say a USB<->SD card adaptor, and do you see the expected files on it under the filesystem?

Hello Jeff

Yes my SD card is correctly programmed as you can see from the attached picture.
This is Debian 9.3 2018-03-05 4GB SD IoT

The image on the eMMC is Debian GNU/Linux 8.4

I have copied the image onto two separate memory cards (both of which worked previously as storage devices) and neither has worked. I’m still keeping the S3 boot button depressed as I power up as I don’t know how to program the board to boot up form the SD card instead,as before the power comes on but nothing else happens.

Any thoughts



Screenshot from 2018-05-24 21-09-08.png