Beaglebone black won't boot


I have a brand new beaglebone black.

I plugged it into to the USB port on my PC.

Absolutely nothing happens, no leds light, nothing on the PC. Does this mean it is dead and needs to be returned to the manufacturer? Is there anything to do to try to get it to boot?


Can you try a different cable, or even the barrel jack ?

If there are still no leds flashing, then it sounds like it is dead or the eMMC is empty.

You could also try flashing an image to an sdcard and booting from that.

Thanks for your reply.
I created an sd card with the image


With the SD card in the powered off board, I plugges in the usb power supply cable while holding the boot button down.

No leds…

If I push the power button the PWR led fflashes blue for an instant.

That’s all I get…

Any thoughts?

Just an instant? that’s usually a sign the tps got fried.


I have now tried to boot with 3 different SD cards and OS


Nothing happens when I hold the boot button down and connect via usb to the PC, nor if I use a power supply directly.

Yes, the pwrt led flashes very briefly if I push the pwr button.

It is a brand new out of the box Beaglebone black.

I’m guessing it’s dead, then?

where did you get it? usually these are burn-in tested…


I got it from waveshare, it’s manufactured by seeed …

Sorry, not sure on their RMA procedure, but yeah, do that…