BeagleBone Blue Bricked

i posted this on element14 as well as the Google forum and thought I might
have some luck here.

So, I loaded the latest Debian image for the Beaglebone boards, Debian 9.5
2018-10-07 4GB SD LXQT, and was using this for a short bit, but for some
reason after trying to run a QT compiled program via remote ssh, the BBBlue
froze and will not boot any more. I powered off the board and when it
powers on only the Green and Red LEDS from the status bank stay constantly
on and the Battery LEDs flash a bit but then 2 stay on constantly; CHG and
the one labeled 75.

I have removed all of the EduMIP connections from the board as well as a n
LCD that was connected but still nothing happens. This board does not have
the FTDI connections like the Black so I do not have a way to get a console
to it to see if it is locking up somewhere.

I've tried removing the uSD card as well as use a known good one but still
no luck.

This board was running fine for sometime now so I am not sure what
happened. It was not until I loaded the new image that I ran into an issue.

NOTE: I did do a 'apt-get install dist-upgrade' which put the Debian
version at 9.6 so I am not sure if that caused an issue but I can not see
it causing a bricked board.

Anyone else run into this issue with the Blue?