BeagleBone boot - where is my bone?

We have a couple of Beaglebones. Our LAN is 90% Windows with a windows domain server, and a few Linux machines. I put a RCN Ubuntu image on one of the Beaglebones. It was unclear to me how to connect to it, and I have never managed to connect using the build in serial port. Eventually I found it had been assigned an IP address, and spent several weeks experimenting with it. I have never even tried to connect to it via a Windows box, only Linux. (Except that I did put a test web page on it and accessed that.)

Over last weekend it apparently had a hardware failure. It appears to be booting (per the LEDs), but it was no longer possible to connect to it. It was also tested with the ‘as-shipped’ SD card with the angstrom image, with different cables, and by different developers trying to connect to different PCs. No joy.

So I am now using a different BeagleBone, but I can only connect to it on our network when using either the unmodified ubuntu image originally from


Or the original angstrom SD card.

If I try with any on which I rebuilt the kernel :


then the BB does not appear on the LAN - even though this identical configuration worked on the previous BeagleBone.

I assume that the identity of the card is partly in the SD card file system (‘hostname’), but that the network would identify it from the mac address. So I booted with the angstrom image, noted the mac address, rebooted with the ubuntu image and looked for that mac address with a network scanner. This worked with the original image referenced in the link above, but for the built kernel images an address was not to be found.

I have some further confusion in that I have connected to an angstrom image using, as per the docs, which implied that this was a fixed address. However, I have also seen the same angstrom image, on the same BB, as an address that was obviously assigned by our server.

So I’m hoping that someone can educate me about how network connectivity is handled differently in all these two cases, and how I can reliably find and connect to any newly imaged BeagleBone. Could something critical have somehow gotten turned off in the kernel config, and if so, what should I be looking for?


Hi mickey,

Just a few remarks that might help.

When using the default image on the bone all you need to do is to
connect the usb to your(preferably linux pc).
A usb hub will appear and a usb serial and network connection will be
visible. This connection is probably
what you mention as being (This would be a link local like address).

The second thing is that the mac address can be changed in
u-boot/kernel (are you having the same mac for
different devices?)

Best is really to get this serial thing going by connecting over usb.


Except that:

  1. The default (angstrom) image has never been at issue, only images I build from RCN’s Ubuntu. Also RCN’s “complete” image works, it’s only when I replace the kernel that it fails, and the replacement kernel is one that worked on a different board.

  2. I have never seen the usb-serial connection with any of the Ubuntu images, and assumed that image was not configured to support the usb-serial connection,

  3. The application I am working towards will need to communicate on the LAN, ideally without depending on a serial connection to get there.

  4. No one has changed the MAC address via uboot on any of the BBs here. Assuming it is hard coded into the ethernet chip I don’t see any reason to do so. If the BBs had the same address I would expect a conflict and the address I was looking for might appear on the scanner even with my own BB off line. Also, I would not expect them to have the same address unless RCN’s and angstroms boot routines both set them to the same value without regard to what is in the hardware. This seems unlikely, but I can look into it. I have not looked at uboot.

  5. “Getting the serial to work over USB” would help with diagnostics, but it does not seem to “just work” for Ubuntu as it does for angstrom, and I’m concerned that making it work could turn into a project in itself.

My puzzle is that code that I built which worked on one BeagleBone does not work on a different BB.

I would expect that when swapping a working SD card from one BB to another the only thing that would change would be the address on the LAN, either as assigned by DHCP based on the MAC address, or if it was hardcoded somewhere on the BB.



Well, it turned out that while the boot image was present on the SD card, for some reason the file system apparently was missing. So the BB booted then sat there twiddling its virtual thumbs. After reformatting the SD card, re-imaging with a file system and boot image, I am now able to re-image just the boot image and all seems to be working as expected.

How and why the file system got zapped is still a mystery (probably dumb user error, that would be me of course…), but one that I’ll ignore unless it happens again. If there had been any error messages during the process I’m sure I would have noted them. “This script has finished successfully…” may not always be 100% true.

I have had the same filesystem corruption problems on my Beaglebone A4 with Ubuntu installed and I have had the same happen with the Beagleboard C3 with Angstrom.

Everything works fine until one day an update causes the problem.
fsck will clear up the errors and several files get sent to lost+found, after that it won't boot and that's the state the Beaglebone is in now.

I have not come across a similar problem on the Pandaboard or the ODROID-X, both running Ubuntu.