Beaglebone Debian OS


I have connected an ethernet cable to my beaglebone, but for some reason I am not able to make SSH connection to it. I also tried connecting the LCD display through HDMI port to see what is going wrong at the bootup due to which SSH connection is not working, but on LCD all it shows is the linux logo at the boot up and then the screen remains blank forever.

Is there a way to solve this issue. I have lot of data in this Beaglebone.


The first diagnostic tool should be a serial cable hooked to the serial command line port.
— Graham

I tried using that as well but it didn’t work.

I can’t believe that you are drawing to the LCD screen, and nothing came out of the Linux command line before that.
Something is wrong with your serial port connection.
— Graham

I had the same problem with the latest builds.

This did not work either: “serial cable hooked to the serial command line port”

Just downgrade to Debian 7.8 (BeagleBone, BeagleBone Black - 4GB SD) 2015-03-01 - more info - md5: c848627722b7a5f7bc89791cc8949e3b
It works like a charm…