BeagleBone errors at startup then login incorrect


We've just received a BeagleBone for our project. For this purpose we
don't need a full UI Linux distribution, so we decided to build ours
through the narcissus image builder (Angstrom). But we can't login on
the board after the boot is finish, the root login doesn't work
("Login incorrect"), but there is some error at the startup.

After few tests it seems that the board doesn't do a "first" complete
boot creating some files, etc.

Here is our process :

- Narcissus image builder packages list :

I'm having the same issue as well with an Angstrom build from
Narcissus. Major pain.

The same thing here…

Has anybody been successful building an image with Narcissus and logging in as root?
If the answer is yes, what are the exact steps to do this?

Best regards,

Hi Guys Any one had any luck with this?

I am stuck with a similar problem.?
and it seems we are the only 3 people in world to have it ... i have
tried NFS boots, SD boots and both give same result.


Hey guys,

I got it to work by simply removing the /etc/securetty file (simple rename will do). This allows root to log in on any interface. However, I just noticed that my root file system is mounted as readonly… oops

For more info (and alternative solutions )read the man pages for login.