BeagleBone Green does not work after kernel update

Hi everyone

I have a BeagleBone Green on my hand and ran with a old kernel from 2017.
I notice the device has some issues and they may lie in the kernel, so I did a kernel update as instructed here.

After the update, I tried to reboot it but it never came up again, so I unplugged the power and powered on again.
The BeagleBone started, but I couldn’t SSH to the device. And the USB is enumerated as USB COM PORT on my PC (WIN10 64bits)

I tried many things to bring it back but it didn’t work.

What should I do now? Should I re-flash the whole image with SD card?

Thanks a lot in advance!

Do you have an FTDI cable you can connect to the BBG?

Also, on your Win10 system, are you getting the Remote NDIS Ethernet interface show for the BBG ?

If you are. check the IP address assigned to this. If you had a shared connection on your Win10 system for the BBG, disable the shared connect and try resetting the USB connection again.

If not, perhaps a driver is missing.




Use the serial console instead of ssh. Then, use this command: ip addr. Find what the ip address to your machine is currently. Then, use that to sign in.


Hello everyone, I need a hand from all of you, if you have a driver for BBG, please reply my email


Pada Minggu, 17 Januari 2021 pukul 13.27.22 UTC+7 set_ menulis: