Beaglebone Kernel build error

Hello All,

I am a newbie in Linux world. I am trying to build the kernel for my Beaglebone a5. The make command gives an error : line 61: warning: here-document at line 24 delimited by end-of-file (wanted `EOF’)

/scripts/mkmakefile: line 62: syntax error: unexpected end of file

I did some googling to solve this problem and I got information that the change was probably introduced with the new version of bash,

bash --version

GNU bash, version 4.2.24(1)-release (x86_64-pc-linux-gnu)

and when I checked mkmakefile with sed -n l I could see the last line EOF is followed by an extra character.I have tried a lot to remove that but failed.

EOF\r$

Please help me to solve this problem and cross compile kernel for my beagle.

ksrenjith <renjith.rohin@gmail.com> [13-02-07 05:32]:

Hello All,

I am a newbie in Linux world. I am trying to build the kernel for my
Beaglebone a5. The make command gives an error : line 61: warning:
here-document at line 24 delimited by end-of-file (wanted `EOF')
/scripts/mkmakefile: line 62: syntax error: unexpected end of file

I did some googling to solve this problem and I got information that the
change was probably introduced with the new version of bash,
# bash --version
GNU bash, version 4.2.24(1)-release (x86_64-pc-linux-gnu)

and when I checked mkmakefile with sed -n l I could see the last line EOF
is followed by an extra character.I have tried a lot to remove that but
failed.

*EOF\r$*
*
*
*Please help me to solve this problem and cross compile kernel for my
beagle.*

--
For more options, visit http://beagleboard.org/discuss
---
You received this message because you are subscribed to the Google Groups "BeagleBoard" group.
To unsubscribe from this group and stop receiving emails from it, send an email to beagleboard+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hi Renjith,

what you see there is a <cr> character -- the extra carriage return,
DOS/WINDOW needs to end a line. Unix needs a <lf> character, which
stands for linefeed, which is recognized in the putput as '$'.

My guess is, that the file in question is in DOS-format.

There are several tools out there like
"fixdos" (http://e.co.za/marius/) or
"dos2unix" (http://sourceforge.net/projects/dos2unix/)
to address this problem of converting DOS-text files to UNIX.

But if you on the way to do it "the UNIX way" you can simply
start vim/vi like this

    vim <your text file>

and give the following commands:

    <ESC>
    :
    set ff<RET>

This should print

    fileformat=dos

Now give this commands

    <ESC>
    :
    set ff=unix<RET>
    :
    wq<RET>

Now the file is written in UNIX-format back to your harddisc.

(<RET> means "press the return/enter key" and <ESC> means "press the
escape key")

HTH!

Best regards,
mcc

THANKS FOR YOUR REPLY,IT IS WORKING FINE NOW,