[beaglebone] lcd7 + qt-embedded touchscreen calibration


I’ve been playing with qt4-embedded a bit on the latest angstrom distro using the latest LCD7 cape, and when I run qtdemoE -qws the touchscreen pointer moves all over the place instead of following my finger. Mouse input works just fine.

I also ran ts_calibrate but that didn’t seem to make a difference.

In regular X, the pointer is pretty accurate.

Has anyone tried the qt4 demos in angstrom using touchscreen?



I just started with Qt on a custom cape with same problem, didn’t try a mouse. Thanks for submitting I will check with the LCD7 to see if it is the same. I see patches in last months issue of the image that a change was made to try to make it more stable. Maybe still a software issue?


It is certainly a software issue, just not sure which part of the software. It feels like a scaling issue to me. As in, the middle 40% of the touchscreen are mapped to the entire screen.

From what I can tell qt-embedded for angstrom isn’t built with tslib (tslib touchscreen input is very stable). I’m trying to rebuild it, but while I’m at it I wanted to enable SGX acceleration because the qt demos put the CPU at 100%. Problem is, it doesn’t look like that works for the bone yet :(.

I might try ubuntu and qt-embedded to see how that works.

Hi I’m running my own qt program and I’m having the same problem, the touch is working but doesn’t follow my finger.
I run /usr/bin/tc_calibrate but same response.
It seems as if the cursors moves faster than the finger.
Anybody knows the solution of this problem?
Thanks in advance.

Talking about the running of touchscrenn using qt programs, in my case, the touchscreen get stuck and I have to change the terminal (Ctrl+F2, Ctrl+F1) to return to the normal running.

2012/8/6 Rai32 <ramon.benavent@gmail.com>

OK guys, found the fix. You need to setup the QWS driver to use tslib:

export QWS_MOUSE_PROTO=Tslib:/dev/input/event0

That fixes the problem.

I fixed the problem:
I download from http://www.angstrom-distribution.org/repo/?section=x11
I put this files in the beaglebone by sftp and install all of them:
#opkg install tslib-calibrate
#opkg install tslib-conf**…**
#opkg install tslib-tests**…**
I executed ts_calibrated and export the lib:
#export QWS_MOUSE_PROTO=LinuxInput:/dev/input/event0

then run
#myapplication -qws
and runs good!!

I tried this, but it’s like the touchscreen stops working completly when I export QWS_MOUSE_PROTO. Any ideas? I tried both LinuxInput and Tslib.

Has anyone solved this problem?


I’ve set three variables:

export QWS_MOUSE_PROTO=“Tslib:/dev/input/touchscreen0” ; Your touchscreen device
export TSLIB_CALIBFILE="/media/mmcblk0p1/pointercal" ; Your calibration file

export TSLIB_TSDEVICE="/dev/input/touchscreen0" ; Touchscreen device again

and it works ok. And it didn’t work without any of this variables.