[BeagleBone] OE/Angstrom build difficulties

Gidday there,

I received my Beaglebone this week and have started getting it set up
to act as the primary robot controller (on top of a NEATO XV-12) using
player/stage. However, I'm having some difficulty getting a build
environment configured. It seems that angstrom-distribution.org is
not entirely stable, so perhaps this is part of my problem.

1) I used the following procedure to try to set it up:

git clone git://git.angstrom-distribution.org/setup-scripts
cd setup-
./oebb.sh config
MACHINE=beaglebone ./oebb.sh bitbake systemd-image

Before executing the last line I set my path as follows

export PATH=$PATH:$PWD/sources/bitbake/bin

Then I ran it and left it going overnight and when I came back, there
was an error in do_rootfs. Logged at


* satisfy_dependencies_for: Cannot satisfy the following dependencies
for task-basic:
* dropbear-systemd *

2) Now when I try to build, I get the following.

$ MACHINE=beaglebone ./oebb.sh bitbake systemd-image
Using $HOME/.oe/environment-oecore to setup needed variables. It is
recommended to do '. /home/jpl/.oe/environment-oecore' and run
'bitbake something' without using ./oebb.sh as wrapper
Executing: MACHINE=beaglebone bitbake systemd-image
ERROR: Layer dependency intel of layer sugarbay not found
ERROR: Layer dependency intel of layer crownbay not found
ERROR: Layer dependency intel of layer emenlow not found
ERROR: Layer dependency intel of layer fishriver not found
ERROR: Layer dependency intel of layer jasperforest not found
ERROR: Layer dependency intel of layer n450 not found

Summary: There were 6 ERROR messages shown, returning a non-zero exit

It's been a couple of years since I've used OE (i.e. where is all this
meta stuff coming from?) but I'm quite familiar with cross-compilation
of root file-systems and all that this implies. I just can't find any
reference to these errors in the forums.

Any hints appreciated.



Please do git pull in your setup-scripts directory. That seems to fix
it for me as it pulls down the latest layers.txt etc. files. Good Luck

Don't do that, oebb.sh takes care of PATH since it needs to do some trickery with bitbake wrappers.

Please do git pull in your setup-scripts directory. That will pull
down the latest layers files. It fixed it for me. Good Luck.

I have been trying this in a number of ways, and still to no good
conclusion. Partly my progress has been slowed by the somewhat
intermittent availability of the Angstrom site, but I noticed some
small differences in the instructions at:


versus the instructions at


So, I re-pulled and ran the following commands.

MACHINE=beaglebone ./oebb.sh config beaglebone
MACHINE=beaglebone ./oebb.sh update
MACHINE=beaglebone ./oebb.sh bitbake systemd-image

After a lot of various git pulls and layer repository syncs (without
any reported errors) and a bunch of lines similar to:

DEBUG: Adding layer /home/jpl/dev/oe/setup-scripts/sources/
DEBUG: LOAD /home/jpl/dev/oe/setup-scripts/sources/openembedded-core/
DEBUG: LOAD /home/jpl/dev/oe/setup-scripts/sources/openembedded-core/

The whole thing ends with:

ERROR: Unable to parse conf/bitbake.conf: ParseError at /home/jpl/dev/
oe/setup-scripts/conf/auto.conf:1: unparsed line: 'MACHINE ?=

Aah, but for some reason I'm on branch oe-core, instead of master, and
I'm missing the latest updates described here:


So checkout master, git pull, re-run the steps aaand....

Okay, now it's building. I guess I'll see the result in the morning.

Thanks for your assistance.


I have been wondering about the oe-core branch myself. Some sites say that this is the one to check out, others just use master. I had no problem with the master brach, but can I assume now, that this is the branch which I am supposed to use?


2012/3/6 Treasurer Trésorier <tresorier@bahailongueuil.org>

The solution to that is *really* easy: Don't trust 'some sites', trust the instructions on the angstrom website.

Well that was the original problem. The official site was unavailable for the first couple of days after I received my beagle bone.

When I got up this morning, my build had completed, so now I can move on to building a player/stage package.



Considering my background I’d love to have beaglebone.cc :slight_smile:
But fair enough what you said, it’s just a lot to come to terms with, with useful information to get started all over the place. Considering that I have my board for just a week now, I am happy what I already achieved, though some things really leave still a lot of question marks.


2012/3/6 Koen Kooi <koen@beagleboard.org>