Beaglebone SPI RFID reader and SPI setup

I am currently struggling to get SPI enabled on my Beaglebone Black. I am running the most recent Debian distribution and have tried just about every conceivable way to try and get SPI enabled. The reason why I want to get SPI enabled is so that I can use the TRF7960/A RFID reader from TI. A few years ago, a group of TI interns developed a cape particularly for this reader ( and posted their code as well as their device tree overlay on Github ( I have tried their instructions as well as the generic ones that are available on e-linux with no success, I have the Beaglebone hooked up to an oscilloscope to test if any data is sent and so far I have not been able to see anything. Furthermore, as far as I can tell, I am not able to enable SPI 0.0. When I try, it shows up as either spidev1.0 or spidev2.0 depending on if I enabled it after SPI 1.0.

Output from “uname -a”:

root@beaglebone:~# uname -a
Linux beaglebone 3.8.13-bone70 #1 SMP Fri Jan 23 02:15:42 UTC 2015 armv7l GNU/Linux

Please help, thank you.