[beaglebone] Still problems with perl: Perl module File::Glob


after installing Perl from source I again tried to ./bootsrap Openbox
from source on my beaglebone.

For this I had to install a couple of additonal modules. Which works
find until I installed File::Glob.

This module was not found by perl regardless whether it was installed
via opkg or from source / cpan.

I am a little clue less at this point, since the same module works
on my PC without question.

What do I have to change to make this working?

Best regards,


For what it’s worth, File::Glob seems to have installed OK on my Beaglebone (after installing Perl from source).

I just tried installing it from cpan, and here is the output:

cpan[1]> install File::Glob
Fetching with HTTP::Tiny:
Going to read ‘/home/root/.cpan/sources/authors/01mailrc.txt.gz’
Fetching with HTTP::Tiny:
Going to read ‘/home/root/.cpan/sources/modules/02packages.details.txt.gz’
Database was generated on Sun, 19 Aug 2012 03:43:03 GMT
HTTP::Date not available

New CPAN.pm version (v1.9800) available.
[Currently running version is v1.960001]
You might want to try
install CPAN
reload cpan
to both upgrade CPAN.pm and run the new version without leaving
the current session.

Fetching with HTTP::Tiny:
Going to read ‘/home/root/.cpan/sources/modules/03modlist.data.gz’
Going to write /home/root/.cpan/Metadata
File::Glob is up to date (1.13).

I know next-to-nothing about Perl, and actually use Webmin to install Perl modules (and Webmin is the only Perl code that I regularly use). Webmin has its own pretty slick interface for finding and installing Perl modules. I wonder if it reconfigured cpan, since I don’t recall setting “cpan.netnitco” as my repository.

If there is anything you’d like me to check about my Perl configuration, let me know.