beaglebone: uboot debug in ccs5 through jtag ( XDS100v2 USB Emulato).

Hi all,
I have a beaglebone and I would like to debug u-boot on it, in ccs5. as I know BB has in-built jtag,
I can connect the board through Texas Instruments XDS100v2 USB Emulator in ccs5 for debug purpose!!
Well, I followed this link to set the target configuration>>>

as in the link I set the configuration then I did “launch the selected configuration”, then in debug window,
right click on cortexA8 to say “connect target”, I got this>>

I would take a look at and the link it has to for an AM335x GEL file. It’s been a long while since I used this all together, but I updated the first link there with instructions for handling relocation in U-Boot, on my Beaglebone White, and nothing too important should have changed since then for debugging BBB.

thanks for the reply tom

but still stuck in the same error on the other hand I tried to use gdb with open ocd, even stuck thr with some errors!!
have u worked with open ocd and gdb, need some help thr also…


hi tom,
see this for helping me on gdb with open ocd to remote debug a program on beaglebone!category-topic/beagleboard/support/advanced/beaglebone/hardware/angstrom/4w0YNXJMba8

I hope u can help me.