Beaglebone Ubuntu Virtual Setup

I have Ubuntu thru Virtual Box on my MAC. I have connection to the internet but I cannot ssh to the beaglebone on the VM. On the MAC terminal, I can do it just fine.

I get a message “ssh: Could not resolve hostname beaglebone.local: Name or service not known”

Any ideas how get this working?


With Virtual Box, are you in "nat" network mode or "bridged"...
(default is nat)... In Bridged mode it will give your virtual box
machine an ip at the same level as the mac os..



I actually just fixed it… I am not sure why this was the solution. First off, I am setting up as NAT. I had to get the MACaddress confirmed on the ssh network, as I work for an institute. I had to do this with the Pi but I didn’t initially do this with the BB because I was communicating with it just find via MAC terminal. This is weird and I cannot explain why this is the case - there was no problem with VB.

Thanks, Cheers,