beaglebone | usb driver | cdc_acm can't load one usb device

hello, I would like to run exotics devices (usb glowing juggling clubs).

1)it works on Arch Linux 2.6.36 x86_64 with cdc_acm :
  usb 4-2: new full speed USB device using uhci_hcd and address 2
  cdc_acm 4-2:1.0: This device cannot do calls on its own. it is no a modem.
  cdc_acm 4-2:1.0: ttyACM0: USB ACM device
  usbcore: registered new interface driver cdc_acm
  cdc_acm v0.26:USB Abstract Control Model Driver for USB modems and ISDN

2)on archlinux 3.2.6-2 x86_64 it was detected as two ftdi_sio (ttyUSB0 and
ttyUSB1) ? i don't know why ?
i can write on /dev/ttyUSB1 it works.

after doing an #rmmod ftdi_sio
my system loads the device with 1 cdc_acm ttyACM0:
  usb 7-1: USB disconnect, device number 5
  usb 7-1: new full-speed USB device number 6 using uhci_hcd
  cdc_acm 7-1:1.0: This device cannot do calls on its own. It is not a modem.
  cdc_acm 7-1:1.0: ttyACM0: USB ACM device

3)but i can't load the driver on my beaglebone with with arm archlinux (or

# lsmod
Module Size Used by
cdc_acm 15041 0
uas 7840 0
ecap 3467 0
pwm 13726 1 ecap

# dmesg
[ 2064.201130] usb 1-1: new full-speed USB device number 7 using musb-hdrc
[ 2069.341624] usb 1-1: unable to read config index 0 descriptor/start: -71
[ 2069.348635] usb 1-1: chopping to 0 config(s)
[ 2069.354634] usb 1-1: string descriptor 0 read error: -71
[ 2069.360195] usb 1-1: New USB device found, idVendor=04d8, idProduct=000a
[ 2069.367246] usb 1-1: New USB device strings: Mfr=1, Product=2,
[ 2069.383080] usb 1-1: no configuration chosen from 0 choices

i tried :
- modprobe cdc_acm vendor=0x04d8 product=0x000a
- modprobe ftdi_sio vendor=0x04d8 product=0x000a
- modprobe usbcore vendor=0x04d8 product=0x000a
- echo vid pid > new_id
- to add vid and pid in the cdc_acm.c driver file

but nothing works

I thought it was may be due to an overcurrent then i tried through a usb hub
but I got the same result.

any idea ?
if not, do you think libusb can be a solution for me to solve this problem ?
note : I do not have the source of the device.

for curious, a link to my device :