Beagleboneblack board is not booting from emmc and SD card.

Hello Experts,
So far my BBB board is worked and able to boot from both eMMC and SD card but suddenly, my board is not booting any more, tried with SD boot too (press and hold the S2 button while power ON) and it doesn’t help.

I am getting nothing on console when I try to boot from eMMC (default, no button press)
I am getting “>” or “<” character on console when I try to boot from SD card (S2 button press)

Can you please help me to findout the issue and how can I debug this issue ?
Thanks for your help.

Hello Titus,

Seth here. I know you may know more about Linux than I. This is why all those commands in the terminal are useful. But, unlike knowing Linux, there are some basics that have helped me outside of learning Linux, i.e. our Debian Distro for the BeagleBone series computers.

  • First…
  • Try other Debian Distros from
  • Another thing I learned is to not mess with some of the internal, Linux tree/file system.- Second…
  • If those two steps do not work, maybe getting some background info. on what happened and when would help.
  • For instance, what type of SD Card are you using? Are you using to write your image file? Did you compress your .img file with a utility, i.e. like 7-zip?
    With those questions answered, I may be able to help but I will need the info. from cat /etc/dogtag and uname -a. Since you cannot start your Linux machine, I cannot retrieve this info. from you.


P.S. Try the updated images at and at If all else fails, type me a message back on this forum. I would like to help but my limited resources may have another person step in.

Hi Mala,
Thanks for your reply and appreciate your help on this.
Its started working once I try to boot from UART.
I am not sure what is the problem, I think it could be board or chip issue and not in SW.