Beagleplay Buildroot eth0 does not come up

For some reason, when I run ifconfig -a after my Beagleplay boots, eth0 is down and I can not use “ifup eth0”, I get “ifup: ignoring unknown interface eth0”. Also, I noticed the wireless interface wlan0 is not even listed in ifconfig -a output. When I run iw, it’s unknown device. What am I missing?

Please share your full serial boot log, i’d like to see what version of u-boot.

Regards,

Looks like uboot doesn’t find it either. I’m using “edvo3_uboot_a53_defconfig” for uboot
CORTEXA build and “edvo3_uboot_r5_defconfig” for CORTEXR uboot build. UBOOT VERSION 2023.04

okay not sure on that config… but 2023.04-00759 smells like TI’s u-boot fork, so wifi should work…

Regards,

I know TI had a problem with different versions of their SK-AM62 dev boards, because I have both versions of the board. One has WIFI onboard, the other doesn’t. That turned out to be a device-tree change, but I checked the Beagleplay device tree to make sure the same change was there and it was. So very weird. I’ll keep digging and let you know what I find.

I got eth0 up & running by switching from TI u-boot to beagleboard u-boot, branch v2024.04-rc3-BeaglePlay. It was successfully built using am62x_evm_a53_defconfig and am62x_evm_r5_defconfig. Once beagleplay booted via microSD, the eth0 interface was up & running. Not quite sure what went wrong with the u-boot from TI I was using.

just note the biggest thing missing on that branch is u-boot “ethernet” support… RFC patches have been posted to u-boot, once i verify they work, i’ll add them to that branch or rc4, depending on what comes first…

Regards,

I did notice the u-boot ethernet had a problem, but the eth0 interface came up during kernel init and it wasn’t doing that before. Now I’m chasing the wlan0 problem. Getting a failure trying to load “regulatory.db”. I have no idea where this file comes from or how to fix this error. Do you?

dmesg output I’m seeing:

[ 1.955396] cfg80211: Loading compiled-in X.509 certificates for reguatabase
[ 1.956760] Loaded X.509 cert ‘sforshee: 00b28ddf47aef9cea7’
[ 1.957521] platform regulatory.0: Direct firmware load for regulatorled with error -2
[ 1.957534] cfg80211: failed to load regulatory.db

I usually build it in…

debian@BeaglePlay-57:~$ dmesg | grep cfg
[    8.051814] cfg80211: Loading compiled-in X.509 certificates for regulatory database
[    8.066999] cfg80211: Loaded X.509 cert 'sforshee: 00b28ddf47aef9cea7'
[    8.067982] cfg80211: Loaded X.509 cert 'wens: 61c038651aabdcf94bd0ac7ff06c7248db18c600'
debian@BeaglePlay-57:~$ zcat /proc/config.gz | grep regulatory
CONFIG_EXTRA_FIRMWARE="regulatory.db regulatory.db.p7s"
debian@BeaglePlay-57:~$ uname -r
6.1.80-ti-arm64-r32

(new maintainer, so new version): kernel/git/wens/wireless-regdb.git - wens's fork of wireless-regdb.git

Regards,