Beagleplay PDF files

I downloaded files with git clone, none of the PDF file are readeable. If I go to the same diirectory using the browser and download the PDF then I can read it with atril,

What is the link?

Cloning it doesn’t work for me either.

I notice those files are marked as LFS, I assume that has something to do with the issue

1 Like


Ok under linux I had to also install git-lfs

Then doing a git clone works as you would expect.

If would have been nice if git clone withput lfs gave some warning.

I just clicked on it in the exposed tree and it opened up.

Have you been able to find the image for that board. Broke mine messing with the device tree. Tried to fix my mistake by jump starting it with TI-62xx demo image. It will boot with that image. Got in and removed the added overlays and it hangs when booting from the original image. Yes, I know what you are going say, did you back the file up…no.

I do have git-lfs installed on Arch Linux and the pdf files downloaded are not recognized by atril as valid pdf files

Ok, just installed Atril v1.26.0 and it has no problems opening the files,

What files sizes have you got ?

2.7M Mar 17 07:00 BeaglePlay_art.pdf
4.9M Mar 17 07:00 BeaglePlay_mech.pdf
1.3M Mar 17 07:00 BeaglePlay_sch.pdf

as obv
Before installing git-lfs the files were in the hundreds of bytes, and opening them in Okular just gave me a hash.

Either your git has not downloaded the files correctly, or your Atril is broken.

-rw-r--r-- 1 michel michel 132   17 mar 17:24 BeaglePlay_art.pdf 
-rw-r--r-- 1 michel michel 15287 17 mar 17:24 BeaglePlay_bom.csv 
-rw-r--r-- 1 michel michel 132   17 mar 17:24 BeaglePlay_mech.pdf 
-rw-r--r-- 1 michel michel 132   17 mar 17:24 BeaglePlay_sch.pdf

Content of BeaglePlay_sch.pdf version oid sha256:02dadb53639d008ffa6fbda4eba59a82a8134cd77696697a81b5afcbe426f556 size 1333365

To get it to work I had to update git and run this

[michel@michel beagleboard]$ git lfs install 
Git LFS initialized. 

LFS is not initialized by default on Arch Linux.

(Updated note: Not sure if this is helpful, but I manually formatted this to try to make it look better on the forum. Discourse should do a better job working off of standard e-mails. --@jkridner)

I noticed that doesn’t display the messages correctly when sent from Thunderbird.

It looks like it is running on windows which requires CR, Linux only use LF
Basically the board is putting the message on one long line.

I haven’t tried these images but this looks promising. Both flasher and non-flasher images are populated: Index of /rootfs/debian-arm64-xfce/2023-03-13

1 Like

Thank you very much for sharing that information.

I have removed git lfs and the files are now normal git binary objects. Sorry it took so long. Please report any issue with reading the files.

I was in the repo uploading the certification documents which are now loaded in there.