Beagleplay u-boot device tree default file question

I am building u-boot for Beagleplay branch v2023.04-ti- I noticed the config file am62x_evm_r5_defconfig contains "CONFIG_DEFAULT_DEVICE_TREE=“k3-am625-r5-sk” and the firagment beagleplay_r5.config contains “CONFIG_DEFAULT_DEVICE_TREE=“k3-am625-r5-beagleplay”. The problem I’m running into is that the DTB files k3-am625-r5-sk.dts and/or k3-am625-r5-beagleplay.dts” are not found in the kernel or u-boot source. Am I missing a patch of some sort for the kernel?

BeaglePlay is now in mainline u-boot, (v2024.01)… Best to just jump to that, here is the list of git tags along with build order: bb-u-boot-beagleplay-debian-12/suite/bookworm/debian/rules · main · / repos-arm64 · GitLab


Thanks for the quick response, will try this out!

One other question for the beagleplay kernel. I’m currently using Beagleboard kernel from branch v6.1.46-ti-arm64-r13. Is this correct?

you should jump to GitHub - beagleboard/linux at v6.1.69-ti-rt-arm64-r20 this has gotten better testing since r13…


Glad I asked!

Now I’m getting the following error, no longer seeing dtb error:

U-Boot SPL 2021.01-gb248392d (Jan 04 2023 - 19:38:45 +0000)
SYSFW ABI: 3.1 (firmware rev 0x0008 ‘8.5.3–v08.05.03 (Chill Capybar’)
SPL initial stack usage: 13424 bytes
Trying to boot from MMC1
Loading Environment from MMC… MMC: block number 0x3500 exceeds max(0x2000)
*** Warning - !read failed, using default environment

init_env from device 9 not supported!
Starting ATF on ARM64 core…

Hold the user button, that’s from the eMMC. It’s best to have the eMMC/microSD version of u-boot match-up…


Nothing happens when I hold the USR button in. No uSD LEDs, it just hangs. Is there some sequence of PWR/RST/USR buttons I need to follow?

On the BeaglePlay, to force microSD to boot when the eMMC is unknown or old…

  • Leave power plugged in
  • push and hold ‘usr’
  • ‘toggle’ reset
  • Let go ‘usr’


Nothing happens when I followed this procedure. I tried the gp, hs, and hs-fs uboot binaries, nothing works. There is no activity at all on the board except for the red power LED.

I have a second Beagleplay using U-Boot 2023.04-00759-g43791d945f (Jan 08 2024 - 10:49:18 -0500). It comes right up using the microSD. The uboot that isn’t working is from 2024.01. I tried the working microSD into the second Beagleplay and it came right up. I’m going to go back to 2023.04 for my second project.

Our debian package bb-u-boot-beagleplay ships all the pre-build binaries under /opt/u-boot/bb-u-boot-beagleplay

Daily builds can also be found here: Index of /public


Got u-boot trying to load from partition 2, but I had to use the older version of u-boot (tag v2023.04-ti- from git site. Now I’m working on the kernel which doesn’t seem to want to come up. Do I need to build fitImage for Beagleplay like I have for other boards in the AM62x family?