BeagleV-Fire and Gateware Updating


beagle@BeagleV:/usr/share/beagleboard/gateware$ sudo ./ ~/artifacts/bitstreams/my_custom_fpga_design
Changing gateware.
No gateware file found.

This is where I am at currently. The fire-gate repo clone from gitlab has not created the gateware so far.


P.S. If you need additional data, please let me know:

# Import HDL source files
import_files -hdl_source {script_support/components/CAPE/fire-cape/HDL/motors.v}
import_files -hdl_source {script_support/components/CAPE/fire-cape/HDL/P8_IOPADS.v}
import_files -hdl_source {script_support/components/CAPE/fire-cape/HDL/P9_11_18_IOPADS.v}
import_files -hdl_source {script_support/components/CAPE/fire-cape/HDL/P9_21_31_IOPADS.v}
import_files -hdl_source {script_support/components/CAPE/fire-cape/HDL/P9_41_42_IOPADS.v}
import_files -hdl_source {script_support/components/CAPE/fire-cape/HDL/CAPE.v}

and… motors.v

`timescale 1ns/100ps

module motors(
input    clk,
input    resetn,
output   motor

reg [22:0] counter;

assign motor = counter[22];

always@(posedge clk or negedge resetn)
      counter <= 16'h0000;
      counter <= counter + 1;


and CAPE.v

P9_41_42_IOPADS P9_41_42_IOPADS_0(
        // Inputs
        .GPIO_OE  ( GPIO_OE_const_net_3 ),
        .GPIO_OUT ( GPIO_OUT_const_net_3 ),
        // Outputs
        .GPIO_IN  (  ),
        // Inouts
        .P9_41    ( P9_41 ),
        .P9_42    ( P9_42 )

motors motors_0(                //
        .clk     ( PCLK ),      //
        .resetn  ( PRESETN ),   //
        .motor   ( MOTOR )      //


wire           PCLK;
wire           PRESETN;
wire           MOTOR;
wire   [31:0]  APB_SLAVE_PRDATA_net_0;
wire   [27:0]  GPIO_IN_net_1;

// Concatenation assignments
assign GPIO_OE_net_0  = { 16'h0000 , GPIO_OE[27:6], 1'b1, GPIO_OE[4:0] };
assign GPIO_OUT_net_0 = { 16'h0000 , GPIO_OUT[27:6], MOTOR, GPIO_OUT[4:0] };

My busted config. in the file seems to be done and over because of me but I do not see where I made this error.


P.S. Please send guidance.

Looks like you added a new cape, yes?

Did you remember to modify:

I can highly recommend watching:

1 Like

Yes @lranders ,

I remembered. I changed it and then changed the .dtso.



I did make it lower case. Blah. I will try again…

@platima goes into a lot of detail on how to spot a build-error.

The build system doesn’t always fail, even with fatal errors, so they’re kinda hard to pin down.

1 Like

Gotcha…thank you.


mixing and matching files is given me the willies.


P.S. I think using the ci is okay but I am not sure. Should I hold off until I feel like I am 100% sure of the build before using the ci?

dh binary
   dh_auto_install --destdir=debian/
dh_install: warning: Cannot find (any matches for) "gateware-builds-tester/artifacts/bitstreams/my_custom_fpga_design/DirectC/*" (tried in ., debian/tmp)
dh_install: warning: missing files: gateware-builds-tester/artifacts/bitstreams/my_custom_fpga_design/DirectC/*
dh_install: warning: Cannot find (any matches for) "gateware-builds-tester/artifacts/bitstreams/my_custom_fpga_design/FlashProExpress/*" (tried in ., debian/tmp)
dh_install: warning: missing files: gateware-builds-tester/artifacts/bitstreams/my_custom_fpga_design/FlashProExpress/*
dh_install: error: missing files, aborting
make: *** [debian/rules:7: binary] Error 25
dpkg-buildpackage: error: debian/rules binary subprocess returned exit status 2
debuild: fatal error at line 1182:
dpkg-buildpackage -us -uc -ui -b failed
Cleaning up project directory and file based variables
ERROR: Job failed: exit code 1

Okay and so…

  1. I do not have gateware-builds-tester at all as a file or dir. obviously but I do not know where to get it.
  2. My artifacts build fails over and over for numerous reasons.
  3. Aw!


The reason I got rid of the and unzip of the file are these reasons:

a. the build failed numerous times
b. I figured the and the inflated .zip files were failures

I’m not entirely sure what I am looking at here…

Could you try and start over with a fresh fork?
In there, I’d like to suggest that you first try and let it run through a build completely unmodified.
Take the artifact from that and try it out the ./ procedure,
just to get a feel for it.

Then, when successful, transplant your code into the DEFAULT cape and repeat.

When successful with that, make a third pass where you try to define your custom cape thing.

I am not trying to patronize you, but this is advanced stuff, and we should crawl before we run.

1 Like

You got it.

I will try. Sluggish over here…bbl!