BeagleV-Fire Build Script Change Request

It was nearly impossible for me to debug my many Verilog bugs (I worked around this by installing Libero on my laptop). @platima provides a solution in his new video at time 17:15 by adding the following line (in bold) to .gitlab-ci.yml. This adds the much needed synthesis log files. Please consider adding this one line to the gateware repo BeagleV-Fire / Gateware · GitLab. Thanks

when: on_success
- gateware-builds-tester/artifacts/
- gateware-builds-tester/builds/*/work/libero/synthesis

@platima’s walk-through is excellent, and even though I am familiar with the build flow, I learned quite a few things.

Sure @BustedWing1 merge requested ci: add synthesis log files (!97) · Merge requests · BeagleV-Fire / Gateware · GitLab posted


I have a major update on the way. I will, include this in it and the relevant following FPGA flow stage reports.


I agree that @platima 's videos are great. Hence the changes on the way to address the issues he highlighted. I have not been able to keep up with your video production @BustedWing1 :smiley:

Thanks for the great feedback! If there is anything I miss, just let me know and I can put it in the next one!

Yeah @BustedWing1 is smashing out some good videos - great to have more support around the RISC-V and FPGA community!

Thanks @Vauban and @platima. Here’s a short I had fun playing around with today. Shorts have to have the rotated aspect ratio. What d’ya thing?

1 Like

Nice work, but personally I loath short form content - I think it’s bad for society as a whole, especially those under 30 that already have attention span issues due to the amount of push notifications, attention-hungry music and expectations of instant gratification these days!

CGP Grey had a really great rant on the societal impacts of it in one of his Cortex podcasts about a year ago, but there’s also a great book I read last year called “Stolen Focus”, which is based a lot around how technology is ingrained in our lives and creates a sense of expectation or urgency.

All good content. Just my 2c though! Happy Friyay ya’ll!

I’ve never been on the ticktock, I don’t have a FB account and I’m very much in agreement with you about push. I tell my kids “it’s your feed because they’re feeding you what they want you to think”. But, back to the short, in just 1 day that silly little video was seen by 1300 people and 350 people watched the entire video. Which, to me, is stunning. So 350ish people learned the name BeagleV-Fire that might have never heard of it… which I think is a potential win. Anyway, I’m gonna play around with shorts and try figure it out. Happy Weekend

1 Like

If you make a flamethrower, do it with the BeagleV-Fire or at least the BBB!


Yeah I’m the same - I have Insta for stock image sales, WhatsApp for work, Reddit for tech, and that’s about it. Tiktok can go die in a hole.

You’re not wrong about shorts/reels though - they capture an audience, however, the point that CGP raised; is that the audience that you want, and is that the sort of engagement you want to drive?

Don’t get me wrong, I just put a shorts out today and I do one maybe every month or two, but I think if you build a channel based on it you’ll build a channel that fails. If you do it to share knowledge that can actually be ingested in a bite size format, then definitely good. But most knowledge that is not news is better educated in long form IMHO, else you have to gloss over too much.

It’s a shame music isn’t what it used to be.

@BustedWing1 , @platima updated beaglev-fire/gateware:

  • Synthesis logs are now included as part of the artifacts
  • Forked repositories can be private and still generate gateware

Also, @platima could you let me know if you still get boot hangs with this update?

To update stock gateware, run these commands on BeagleV-Fire:

sudo apt install software-properties-common
sudo add-apt-repsitory "deb [trusted=yes] stable main"
sudo apt install
sudo apt update
sudo apt upgrade
cd /usr/share/beagleboard/gateware
sudo ./ default

You only need to run the first 3 commands once on your boards and the remaining 4 every time you want to upgrade the gateware to the latest version.

Yeah no worries will give it a crack this weekend.

What do you think it was in the DDR training that was crashing?

Edit: Nvm just saw commit d727158310374fb45b7d013906481885e1644970.

@Vauban I tried to create a fork of the gateware repo, but since I already have a fork, gitlab won’t let me create a 2nd fork. This is just so I can try out your updates. I don’t want to mess with my original fork. Any ideas? Thanks!

Okay stack overflow to the rescue… (GitLab oddity)

  • In the project you forked into, go to settings > general > advanced > “remove fork relationship”.
  • Now go to the source project and the button to fork is available again.


@RobertCNelson That worked. I love SO
@Vauban I forked, built and got nice reports and logs. I’m happy. Thanks

Sorry mate finally got back around to this, been a tad hectic.

My snakeyware was based on 0.4.0-39, and I was getting the crashes. This package appears to be 0.4.0-27, but I wrote it to fabric anyway.

Seemed to work well - DDR training passed every time bloody quick; 1.5-1.7s.


Cool. Thanks for checking.