BeagleY-AI: unable to boot

I’ve followed the instructions at BeagleY-AI Quick Start — BeagleBoard Documentation to create a 32gb microsd card with the latest image, with customizations for username/password/wifi settings. When I attempt to boot the board, either by connecting via usb-c to a laptop to get the internal network or via a 65w usb-c adapter, the board seems to not boot. The led goes from red to flashing green (pattern: 2 green flashes and a pause, repeat) but I am never able to connect to the board using any of the listed methods. I tried finding documentation on what the led pattern means but so far haven’t found anything. Any tips on next steps, please? I was going to try to connect the board to a router via a cable and also via hdmi to see if I can see anything more useful.

For the LED’s…

red = in u-boot
green = kernel starting up… (linux heartbeat)

When plugged into your laptop, Windows, Linux or mac?

Linux: should be: (grabs my board, old image reflashing…)

Bus 005 Device 016: ID 1d6b:0104 Linux Foundation Multifunction Composite Gadget
[233724.855522] usb 5-2.4.2: new high-speed USB device number 16 using xhci_hcd
[233724.967031] usb 5-2.4.2: New USB device found, idVendor=1d6b, idProduct=0104, bcdDevice= 4.04
[233724.967041] usb 5-2.4.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[233724.967045] usb 5-2.4.2: Product: BeagleY-AI
[233724.967048] usb 5-2.4.2: Manufacturer:
[233724.967051] usb 5-2.4.2: SerialNumber: 1234BBBK5678
[233725.113963] rndis_host 5-2.4.2:1.0 eth0: register 'rndis_host' at usb-0000:13:00.3-2.4.2, RNDIS device, 1c:ba:8c:a2:ed:6a
[233725.136271] cdc_ncm 5-2.4.2:1.2: MAC-Address: 1c:ba:8c:a2:ed:6c
[233725.136442] cdc_ncm 5-2.4.2:1.2 eth1: register 'cdc_ncm' at usb-0000:13:00.3-2.4.2, CDC NCM (NO ZLP), 1c:ba:8c:a2:ed:6c
[233725.137470] cdc_acm 5-2.4.2:1.4: ttyACM1: USB ACM device
[233725.153116] rndis_host 5-2.4.2:1.0 enx1cba8ca2ed6a: renamed from eth0
[233725.153303] cdc_ncm 5-2.4.2:1.2 enx1cba8ca2ed6c: renamed from eth1

On windows it’ll look like this:

I was using a macos laptop but I also tried with a win11 laptop. I am currently trying to boot it connected to the router via a network cable. The led is still doing the two-fast-flashes followed by a short pause and the network interface has one solid light on the left and an intermittently flashing led on the right of the connector. Edit: I left it plugged in for an hour or two like that and the power led behavior never changed (this is with direct power and to each of the laptops) - the board got quite warm though.

So it’s up… On mac, avahi/bonjour… ‎Discovery - DNS-SD Browser on the Mac App Store should find it’s ip address…


My current software image is just a bit older…

jkridner@lego ~ % ssh beagley-2.local
The authenticity of host 'beagley-2.local (2601:408:c000:eac0::5dfb)' can't be established.
ED25519 key fingerprint is SHA256:f9G5bbngzfVY5J2FifChjXfMMnHFUZIktvS8TyZuzTA.
This key is not known by any other names.
Are you sure you want to continue connecting (yes/no/[fingerprint])? yes
Warning: Permanently added 'beagley-2.local' (ED25519) to the list of known hosts.
Debian GNU/Linux 12 Debian Bookworm Xfce Image 2024-06-12
default username is [beagle]

jkridner@beagley-2.local's password: 

jkridner@lego ~ % ssh beagle@beagley-2.local
Debian GNU/Linux 12 Debian Bookworm Xfce Image 2024-06-12
default username is [beagle]

beagle@beagley-2.local's password: 

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.

Yes, that happens. I had the same problem, you will need to get a connector for the ttl debug port to see what is actually going on. The heartbeat seems to be from intramfs, not the “real file system” that is used to mount all the other stuff. It hangs when it tries to access p3 of the SD card. Mine was hit and miss then nothing. Nothing is running other than heartbeat and unable to mount the “real” file system so it will be dead on ethernet too.

Here is a WILD thought, not for fact. Might be tied to a thermal issue/drift/timing/(any guess will do), and if you put it in the freezer for a few hours and then try boot it might work. I have not done this on my bad board, we have done testing in the freezer in the past and stuff does run differently. It did get worse as is warmed up.

That ti3boot is something I would possibly point a finger at, might be a Ti issue and the hardware its self is physically fine. We have a couple of am64 eval boards and they have never booted, even using the SD cards Ti suggested.

Getting Nvidia flashbacks re. the freezer :slight_smile: - but I guess I’m desperate enough to try it if the boot of the older image fails. So strange.

Thanks - I think I’ll try to find an image older than the one from 06-19 to see if that works out better.

Grab this one…

Make sure to set the password in bb-imager, you’ll need to select the (use custom) option and select your download of ^

Unfortunately I’m still getting the same thing, i.e. the led flashing. I’ll keep trying to plug away at it but I’m getting the feeling maybe I have a bad board. Thanks for all of the help so far and hopefully I will get to a prompt soon enough.

What do you see when you power it from your Windows device? Using this usb tool to see what it reports as: USB Device Tree Viewer


Same issue here. Red led soon changes to green heartbeat but not able to connect.

ifconfig shows nothing for the tethered USB. The router also is unaware it exists.
lsusb on the tethered host shows nothing relevant. Neither does journalctl.

Interestingly, browsing the files on the sd card, the /BOOT/sysconf.txt file still shows the changes I made to the username and password - I was under the impression that these settings would be read on boot then the file reverted. Also, the /etc/passwd file is not updated with the new user details. Seems to be an issue with reading the sysconf.txt file?

Red led (in u-boot)
Green led (in Linux reading sysconfig.txt)
1 to 2 minutes setting sysconfig.txt values, generate ssh keys and reboot
Red led (in u-boot)
Green led (in Linux)
Networking up (TYPEC - USB serial, USB networking)
Xfce starts up on HDMI

Are you saying it should reboot automaticly after processing sysconf.txt? I’m not seeing that. After multiple manual reboots (just pull the power, since I cant log in) there is no network - USBC or ethernet, and the username and password are not updated. There is no HDMI ouput.

@bbbpaul is yours also overheating after a while? My board gets hot enough to be uncomfortable to hold after a few minutes of the green led flashing. The datecode on mine is 202405 and I got it from Digikey.

Correct it’ll take about 1 to 2 minutes and reboot on it’s own.

What is the serial number on the tag on ethernet jack. Mine is around 2xx.

@RobertCNelson I’m not seeing it reboot, even after many minutes.

@abaustx no overheating just slight warming, just as I’d expect.

@foxsquirrel Date code 202405, SN 500?

Okay uploaded a video of what would normally happen on the board and led:

Our only real requirment is that you as the user set the User Password field:


1 Like

Are you on the debug port? Neither of the boards here output any thing on the monitor, after a wait the cursor comes then after a while desktop is up. Using the factory image I downloaded.