Black Wireless powers up on its own after shutdown

Zmatt,

You and I have been here before twice. My BBB’s do the same thing if dual powered. Restart. Single supply shut down.

KenUnix

I do have a scope so I’ll check that out. I’m single powered just from a 5V DC barrel. No USB is connected.

As the post is a few month old, and for making it a reference, shuting down the BBB with “sudo halt” does the job for me (intead of issueing the “sudo shutdown now” command in order to poweroff the board).

halt does not power off the system at all, it merely halts it (power led remains on).

I just took delivery of some new Beaglebone Green Wireless boards, version 1.1. They are also refusing to power down and instead immediately reboot. This happens with a single power supply (USB), and even if I use the command “systemctl poweroff”. I don’t have this problem with the version 1.0 boards.

The version 1.1 boards also refuse to run bluetooth under the 4.19 kernel (Kernel 4.19.x does not work on BeagleBone Green Gateway · Issue #59 · RobertCNelson/bb-kernel · GitHub), but that’s another story…

Bluetooth: BeagleBone Green Wireless or BeagleBone Green Gateway?

For the Green Gateway:

Grab a newer snapshot:

or:

For the Green Gateway i had to move bluetooth back to hciattach for initialization vs the in-kernel method…

If it is really a Green Wireless, then that would be a new bug…

Regards,

Yes, it’s definitely a BeagleBone Green Wireless, with hardware version 1.1. I’m now running bullseye on it (upgraded from buster via apt to fix the bluetooth bug). I’m happy that uio_pruss is now working under 5.10 (thanks to GitHub - mvduin/overlay-utils: Making BBB overlays easier), but my new problem is the inability to power it down. Here’s the output of beagle-version:

eeprom:[A335BNLTGW1ABBGW19010472]
model:[TI_AM335x_BeagleBone_Green_Wireless]
dogtag:[BeagleBoard.org Debian Buster IoT Image 2020-05-18]
bootloader:[eMMC-(default)]:[/dev/mmcblk1]:[U-Boot SPL 2019.04-00002-g31a8ae0206 (May 13 2020 - 09:26:17 -0500)]:[location: dd MBR]
bootloader:[eMMC-(default)]:[/dev/mmcblk1]:[U-Boot 2019.04-00002-g31a8ae0206]:[location: dd MBR]
UBOOT: Booted Device-Tree:[am335x-boneblack-uboot.dts]
UBOOT: Loaded Overlay:[BB-BBGW-WL1835-00A0.bb.org-overlays]
UBOOT: Loaded Overlay:[BB-BONE-eMMC1-01-00A0.bb.org-overlays]
UBOOT: Loaded Overlay:[uio-pruss-5.4]
kernel:[5.10.106-ti-r41]
/boot/uEnv.txt Settings:
uboot_overlay_options:[enable_uboot_overlays=1]
uboot_overlay_options:[uboot_overlay_addr4=/lib/firmware/CT-INPUT-KEYS-00A0.dtbo]
uboot_overlay_options:[uboot_overlay_addr5=/lib/firmware/CT-PWM-P8_34-00A0.dtbo]
uboot_overlay_options:[uboot_overlay_addr6=/lib/firmware/CT-EGPIO-00A0.dtbo]
uboot_overlay_options:[disable_uboot_overlay_video=1]
uboot_overlay_options:[disable_uboot_overlay_audio=1]
uboot_overlay_options:[disable_uboot_overlay_adc=1]
uboot_overlay_options:[uboot_overlay_pru=/lib/firmware/uio-pruss-5.4.dtbo]
pkg check: to individually upgrade run: [sudo apt install --only-upgrade ]
pkg:[bb-cape-overlays]:[4.14.20210821.0-0~bullseye+20210821]
pkg:[bb-customizations]:[1.20220325.0-0~bullseye+20220325]
pkg:[bb-usb-gadgets]:[1.20220316.1-0~bullseye+20220316]
pkg:[bb-wl18xx-firmware]:[1.20211222.2-0~bullseye+20211222]
pkg:[kmod]:[28-1]
WARNING:pkg:[librobotcontrol]:[NOT_INSTALLED]
pkg:[firmware-ti-connectivity]:[20210315-3]
groups: ‘debian’: no such user
groups:[]
cmdline:[console=ttyO0,115200n8 bone_capemgr.uboot_capemgr_enabled=1 root=/dev/mmcblk1p1 ro rootfstype=ext4 rootwait coherent_pool=1M net.ifnames=0 lpj=1990656 rng_core.default_quality=100 quiet]
dmesg | grep remote
[ 3.895331] remoteproc remoteproc0: wkup_m3 is available
[ 28.765539] remoteproc remoteproc0: powering up wkup_m3
[ 28.765576] remoteproc remoteproc0: Booting fw image am335x-pm-firmware.elf, size 217148
[ 28.765835] remoteproc remoteproc0: remote processor wkup_m3 is now up
[ 40.130791] Bluetooth: hci0: change remote baud rate command in firmware
dmesg | grep pru
dmesg | grep pinctrl-single
[ 3.721640] pinctrl-single 44e10800.pinmux: 142 pins, size 568
[ 3.848210] pinctrl-single 44e10800.pinmux: pin PIN30 already requested by 481a6000.serial; cannot claim for leds
[ 3.858818] pinctrl-single 44e10800.pinmux: pin-30 (leds) status -22
[ 3.865309] pinctrl-single 44e10800.pinmux: could not request pin 30 (PIN30) from group pinmux_bt_pins on device pinctrl-single
dmesg | grep gpio-of-helper
lsusb
Bus 001 Device 002: ID 05e3:0610 Genesys Logic, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
END

Thanks!

Ah there’s the issue for Bluetooth…

Since it’s using the *bb.org-overlays"…

UBOOT: Booted Device-Tree:[am335x-boneblack-uboot.dts]
UBOOT: Loaded Overlay:[BB-BBGW-WL1835-00A0.bb.org-overlays]
UBOOT: Loaded Overlay:[BB-BONE-eMMC1-01-00A0.bb.org-overlays]
UBOOT: Loaded Overlay:[uio-pruss-5.4]

I’d first try updating u-boot, as this will use the kernel path for overlays…

sudo apt update
sudo apt install bb-u-boot-am335x-evm
sudo /opt/u-boot/bb-u-boot-am335x-evm/install.sh
sudo reboot

Then retest beagle-version

Edit it should look similar to this…

UBOOT: Booted Device-Tree:[am335x-bonegreen-wireless-uboot-univ.dts]
UBOOT: Loaded Overlay:[BB-ADC-00A0.kernel]
UBOOT: Loaded Overlay:[BB-BBGW-WL1835-00A0.kernel]
UBOOT: Loaded Overlay:[BB-BONE-eMMC1-01-00A0.kernel]
kernel:[5.15.29-bone22]

Regards,

I’ll have to go back to buster/4.19 in order to test this - hopefully that was the problem there. I did update u-boot after I noticed the same thing that you did and no longer saw the PIN30 error. I still can’t shut down the v1.1 BBGW boards without them immediately rebooting.

Here’s what I see when I run “systemctl poweroff” on version 1.1 BBGW boards. Version 1.0 boards immediately power down:

[ 264.212466] reboot: Power down

U-Boot SPL 2022.04-g4237220b (Apr 08 2022 - 13:42:29 +0000)
Trying to boot from MMC2

U-Boot 2022.04-g4237220b (Apr 08 2022 - 13:42:29 +0000)

CPU : AM335X-GP rev 2.1
Model: TI AM335x BeagleBone Black
DRAM: 512 MiB
Reset Source: Power-on reset has occurred.
RTC 32KCLK Source: External.
Core: 150 devices, 14 uclasses, devicetree: separate
WDT: Started wdt@44e35000 with servicing (60s timeout)
MMC: OMAP SD/MMC: 0, OMAP SD/MMC: 1
Loading Environment from EXT4… Board: BeagleBone Black
not set. Validating first E-fuse MAC
BeagleBone Black:
Model: SeeedStudio BeagleBone Green Wireless:

Thanks so much for what you do - you’re an incredible asset to this community.

FWIW, here’s the latest output from beagle-version under bullseye/5.10

eeprom:[A335BNLTGW1ABBGW21114679]
model:[TI_AM335x_BeagleBone_Green_Wireless]
dogtag:[BeagleBoard.org Debian Buster IoT Image 2020-05-18]
bootloader:[eMMC-(default)]:[/dev/mmcblk1]:[U-Boot SPL 2022.04-g4237220b (Apr 08 2022 - 13:42:29 +0000)]:[location: dd MBR]
UBOOT: Booted Device-Tree:[am335x-boneblack-uboot.dts]
UBOOT: Loaded Overlay:[BB-BBGW-WL1835-00A0.kernel]
UBOOT: Loaded Overlay:[BB-BONE-eMMC1-01-00A0.kernel]
UBOOT: Loaded Overlay:[uio-pruss-5.4]
kernel:[5.10.106-ti-r41]
/boot/uEnv.txt Settings:
uboot_overlay_options:[enable_uboot_overlays=1]
uboot_overlay_options:[uboot_overlay_addr4=/lib/firmware/CT-INPUT-KEYS-00A0.dtbo]
uboot_overlay_options:[uboot_overlay_addr5=/lib/firmware/CT-PWM-P8_34-00A0.dtbo]
uboot_overlay_options:[uboot_overlay_addr6=/lib/firmware/CT-EGPIO-00A0.dtbo]
uboot_overlay_options:[disable_uboot_overlay_video=1]
uboot_overlay_options:[disable_uboot_overlay_audio=1]
uboot_overlay_options:[disable_uboot_overlay_adc=1]
uboot_overlay_options:[uboot_overlay_pru=/lib/firmware/uio-pruss-5.4.dtbo]
pkg check: to individually upgrade run: [sudo apt install --only-upgrade ]
pkg:[bb-cape-overlays]:[4.14.20210821.0-0~bullseye+20210821]
pkg:[bb-customizations]:[1.20220325.0-0~bullseye+20220325]
pkg:[bb-usb-gadgets]:[1.20220316.1-0~bullseye+20220316]
pkg:[bb-wl18xx-firmware]:[1.20211222.2-0~bullseye+20211222]
pkg:[kmod]:[28-1]
WARNING:pkg:[librobotcontrol]:[NOT_INSTALLED]
pkg:[firmware-ti-connectivity]:[20210315-3]
groups: ‘debian’: no such user
groups:[]
cmdline:[console=ttyS0,115200n8 root=/dev/mmcblk1p1 ro rootfstype=ext4 rootwait coherent_pool=1M net.ifnames=0 lpj=1990656 rng_core.default_quality=100 quiet]
dmesg | grep remote
[ 3.848095] remoteproc remoteproc0: wkup_m3 is available
[ 30.337012] remoteproc remoteproc0: powering up wkup_m3
[ 30.337052] remoteproc remoteproc0: Booting fw image am335x-pm-firmware.elf, size 217148
[ 30.337481] remoteproc remoteproc0: remote processor wkup_m3 is now up
[ 44.158929] Bluetooth: hci0: change remote baud rate command in firmware
dmesg | grep pru
dmesg | grep pinctrl-single
[ 3.709498] pinctrl-single 44e10800.pinmux: 142 pins, size 568
dmesg | grep gpio-of-helper
lsusb
Bus 001 Device 002: ID 0424:2514 Microchip Technology, Inc. (formerly SMSC) USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
END

OK, I reflashed a v1.1 BBGW board back to buster/4.19, updated u-boot, and bluetooth still doesn’t work. The board hard hangs after it fails to download the bluetooth firmware:

[ 36.489141] Bluetooth: hci0: command 0xfd06 tx timeout
[ 44.521116] Bluetooth: hci0: send command failed
[ 44.525891] Bluetooth: hci0: download firmware failed, retrying…

I did manage to capture the output of version.sh before it locked up:

git:/opt/scripts/:[2338ea72e66525937309923c4bf22bc7cbb450b9]
eeprom:[A335BNLTGW1ABBGW21114679]
model:[TI_AM335x_BeagleBone_Green_Wireless]
dogtag:[BeagleBoard.org Debian Buster IoT Image 2020-05-18]
bootloader:[eMMC-(default)]:[/dev/mmcblk1]:[U-Boot SPL 2019.04-g923f8b8 (Jan 02 2022 - 19:05:15 +0000)]:[location: dd MBR]
bootloader:[eMMC-(default)]:[/dev/mmcblk1]:[U-Boot 2019.04-g923f8b8]:[location: dd MBR]
UBOOT: Booted Device-Tree:[am335x-boneblack-uboot.dts]
UBOOT: Loaded Overlay:[AM335X-PRU-UIO-00A0]
UBOOT: Loaded Overlay:[BB-BBGW-WL1835-00A0.kernel]
UBOOT: Loaded Overlay:[BB-BONE-eMMC1-01-00A0.kernel]
kernel:[4.19.94-ti-r72]
/boot/uEnv.txt Settings:
uboot_overlay_options:[enable_uboot_overlays=1]
uboot_overlay_options:[uboot_overlay_addr4=/lib/firmware/CT-INPUT-KEYS-00A0.dtbo]
uboot_overlay_options:[uboot_overlay_addr5=/lib/firmware/CT-PWM-P8_34-00A0.dtbo]
uboot_overlay_options:[uboot_overlay_addr6=/lib/firmware/CT-EGPIO-00A0.dtbo]
uboot_overlay_options:[disable_uboot_overlay_video=1]
uboot_overlay_options:[disable_uboot_overlay_audio=1]
uboot_overlay_options:[disable_uboot_overlay_adc=1]
uboot_overlay_options:[uboot_overlay_pru=/lib/firmware/AM335X-PRU-UIO-00A0.dtbo]
pkg check: to individually upgrade run: [sudo apt install --only-upgrade ]
pkg:[bb-cape-overlays]:[4.14.20210821.0-0~buster+20210821]
pkg:[bb-customizations]:[1.20220325.0-0~buster+20220325]
pkg:[bb-usb-gadgets]:[1.20220316.1-0~buster+20220316]
pkg:[bb-wl18xx-firmware]:[1.20211222.2-0~buster+20211222]
pkg:[kmod]:[26-1]
WARNING:pkg:[librobotcontrol]:[NOT_INSTALLED]
pkg:[firmware-ti-connectivity]:[20190717-2rcnee1~buster+20200305]
groups: ‘debian’: no such user
groups:[]
cmdline:[console=ttyS0,115200n8 root=/dev/mmcblk1p1 ro rootfstype=ext4 rootwait coherent_pool=1M net.ifnames=0 lpj=1990656 rng_core.default_quality=100 quiet]
dmesg | grep remote
[ 26.432221] remoteproc remoteproc0: wkup_m3 is available
[ 26.583569] remoteproc remoteproc0: powering up wkup_m3
[ 26.583603] remoteproc remoteproc0: Booting fw image am335x-pm-firmware.elf, size 217148
[ 26.583883] remoteproc remoteproc0: remote processor wkup_m3 is now up
[ 28.428980] Bluetooth: hci0: change remote baud rate command in firmware
dmesg | grep pru
dmesg | grep pinctrl-single
[ 0.863336] pinctrl-single 44e10800.pinmux: 142 pins, size 568
dmesg | grep gpio-of-helper
[ 0.864603] gpio-of-helper ocp:cape-universal: ready
lsusb
Bus 001 Device 002: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
END

I also reflashed a v1.0 board back to buster/v4.19, did the same update of u-boot, and both the bluetooth and power down worked fine. It still generates the failed firmware download warning, but then recovers and bluetooth works normally. I’m attaching a picture of the v1.0 and v1.1 boards side by side, and you can see that there has been a significant redesign. I’ve found nothing online documenting these changes.
IMG_6400

ugh… that was the same bug that affected the BeagleBone Green Gateway…

I’ve pinged Seeed for a 1.1 schematic change… Where did you get your 1.1 board? i need to order one…

i’m thinking i’ll need to move the bluetooth initialization back out of the kernel again to the hciattch script…

Regards,

I ordered it direct from Seeed.

I have extras and can send you one if you’d like.

No Worries, i’ll wait on Seeed…

Ps give this a try… You’ll have to install it first on the one that boots, then move the card over…

git clone -b v4.19.x-ti-overlays https://github.com/beagleboard/BeagleBoard-DeviceTrees
cd ./BeagleBoard-DeviceTrees/
make
sudo make install

Regards,

That seems to have fixed the bluetooth problem, thanks! Version 1.1 board still won’t power down though. Also see this on the console immediately after I execute systemctl poweroff:

[ 39.619097] Bluetooth: hci0: sending frame failed (-49)

Just a quick update on this, i’ve merged the Device Tree change, so 4.19.94-ti-r73 is now safe for you to upgrade too…

Regards,

That seems to work for 4.19. I also tried upgrading from 5.10.106-ti-r41 to 5.10.106-ti-r42, but that unfortunately broke bluetooth again on the BBGW v1.1…

hi @ridgelift that’s disappointing, ‘r42’ has the same changes… please run…

sudo beagle-version

Regards,

Here’s the output of beagle-version just prior to upgrading the kernel with update_kernel.sh. After the kernel upgrade bluetooth no longer works and I have to reflash to go back. Let me know if you need to see the output after the upgrade.

eeprom:[A335BNLTGW1ABBGW20110520]
model:[TI_AM335x_BeagleBone_Green_Wireless]
dogtag:[BeagleBoard.org Debian Buster IoT Image 2020-05-18]
bootloader:[eMMC-(default)]:[/dev/mmcblk1]:[U-Boot SPL 2022.04-g4237220b (Apr 08 2022 - 13:42:29 +0000)]:[location: dd MBR]
UBOOT: Booted Device-Tree:[am335x-boneblack-uboot.dts]
UBOOT: Loaded Overlay:[BB-BBGW-WL1835-00A0.kernel]
UBOOT: Loaded Overlay:[BB-BONE-eMMC1-01-00A0.kernel]
UBOOT: Loaded Overlay:[uio-pruss-5.4]
kernel:[5.10.106-ti-r41]
/boot/uEnv.txt Settings:
uboot_overlay_options:[enable_uboot_overlays=1]
uboot_overlay_options:[uboot_overlay_addr4=/lib/firmware/CT-INPUT-KEYS-00A0.dtbo]
uboot_overlay_options:[uboot_overlay_addr5=/lib/firmware/CT-PWM-P8_34-00A0.dtbo]
uboot_overlay_options:[uboot_overlay_addr6=/lib/firmware/CT-EGPIO-00A0.dtbo]
uboot_overlay_options:[disable_uboot_overlay_video=1]
uboot_overlay_options:[disable_uboot_overlay_audio=1]
uboot_overlay_options:[disable_uboot_overlay_adc=1]
uboot_overlay_options:[uboot_overlay_pru=/lib/firmware/uio-pruss-5.4.dtbo]
pkg check: to individually upgrade run: [sudo apt install --only-upgrade ]
pkg:[bb-cape-overlays]:[4.14.20210821.0-0~bullseye+20210821]
pkg:[bb-customizations]:[1.20220325.0-0~bullseye+20220325]
pkg:[bb-usb-gadgets]:[1.20220316.1-0~bullseye+20220316]
pkg:[bb-wl18xx-firmware]:[1.20211222.2-0~bullseye+20211222]
pkg:[kmod]:[28-1]
WARNING:pkg:[librobotcontrol]:[NOT_INSTALLED]
pkg:[firmware-ti-connectivity]:[20210315-3]
groups: ‘debian’: no such user
groups:[]
cmdline:[console=ttyS0,115200n8 root=/dev/mmcblk1p1 ro rootfstype=ext4 rootwait coherent_pool=1M net.ifnames=0 lpj=1990656 rng_core.default_quality=100 quiet]
dmesg | grep remote
[ 3.852102] remoteproc remoteproc0: wkup_m3 is available
[ 29.261015] remoteproc remoteproc0: powering up wkup_m3
[ 29.261055] remoteproc remoteproc0: Booting fw image am335x-pm-firmware.elf, size 217148
[ 29.261355] remoteproc remoteproc0: remote processor wkup_m3 is now up
[ 40.501263] Bluetooth: hci0: change remote baud rate command in firmware
dmesg | grep pru
dmesg | grep pinctrl-single
[ 3.712010] pinctrl-single 44e10800.pinmux: 142 pins, size 568
dmesg | grep gpio-of-helper
lsusb
Bus 001 Device 002: ID 05e3:0610 Genesys Logic, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
END