Bluetooth on Beagle

Hi all,

I built my USB bluetooth driver successfully on Beagle board.

After building and copying the resulted ko (i named my driver usbluetooth.ko) to /lib/modules/2.6.29-omap1/kernel/drivers/myBTdriver/ , I ran these 2 commands as I had done on my Linux PC (I had built and run this USB Bluetooth successfully on the Linux PC):

depmode -a
modeprobe usbluetooth

Then I can view my driver info by :

modinfo usbluetooth

But when I lsmod , my driver is not listed !

Then I cd to the folder of my ko driver (which is **/lib/modules/2.6.29-omap1/kernel/drivers/myBTdriver/**usbluetooth.ko) and tried :
insmod usbluetooth.ko

This error happened :

insmod: error inserting ‘usbluetooth.ko’: -1 Invalid parameters

Please tell me what could cause the above error happen ?
lsmod does not list my driver, which means my driver is not loaded successfully yet; so how could I view my driver info by modinfo as on the 3rd command above?

I appreciate any responses.

with insmod bluetooth.ko it’s expecting some external parameter that can be viewed using modinfo usbbluetooth params section.

Hi amol,

Thanks for your reply; but could you describe more clearly about the
"external parameter" that you mentioned : where can I find it in
modinfo ?




You can use dmesg to see what's going with the module insertion.


Hi Hieu,

Thanks for the great command!!

After I tried :

insmod /lib/modules/2.6.29-omap1/kernel/drivers/myBTdriver/


modprobe usbluetooth

, dmesg reports the same message : ***usbluetooth: module is already
loaded*** (1)

Then I tried : rmmod usbluetooth

The CONSOLE outputs : ***ERROR: Module usbluetooth does not exist in /
proc/modules*** (2)

I also tried to rmmod all of the loaded modules to make sure there is
no security modules blocking my insmod'ing and restarted the sequence
but the errors are still the same.

Hi Quan.

Have you perhaps built bluetooth into the kernel? That is, put a 'Y' instead
of an 'M' next to CONFIG_BT?

Unfortunately, I'm not familiar with bluetooth, so I don't know how, but you
should test whether you have bluetooth support already. Perhaps there are
bluetoothy things in /dev?



One difference I notice between the drivers built on my Linux PC and
Beagle board :

On Linux PC :
modinfo usbluetooth
.......... <driver's info>
depends : usbcore

On Beagle board :
modinfo usbluetooth
.......... <driver's info>
depends : <EMPTY>

I already had a built-in usb driver on OMAP.

Why is it empty at "depends" field ?