Board stuck booting! Waiting for root device /dev/mmcblk0p2...

Hi everyone,

My board has all of a sudden stopped booting. It was working fine a
minutes ago, and now nothing.

I get the following message where it goes no further.

twl4030_rtc twl4030_rtc: setting system clock to 2000-01-01 00:00:00
UTC (94668)
Waiting for root device /dev/mmcblk0p2...

does anyone know what the cause may be and how I could resolve?

I don't know if you need to know this but my board is Rev B.

Thank you,


Perhaps your partition has gone bad or disappeared.
I suggest an fsck of your sd card on a linux system.
Otherwise maybe your card is broken.


I had this issue as well... however I was trying different linux

My board would boot perfectly with the rootfs on mmc with kernel
2.6.28-omap-r25, as came with the openembedded env, however when I
tried 2.6.29 with the omap3_beagle_defconfig, it would hang waiting
for the root device.

Adding a rootdelay did not solve the problem.

I also tried 2.6.30-rc3 but it oopsed early on in boot when trying to
some linking with sysfs.

Did fsck'ing your card change anything?


Hi there,

thanks for your responses.

Well I've tried fsck but it had no effect. I will try a new SD card
tomorrow. I have a feeling my SD reader is playing up a bit so ill go
and get a new one tomorrow and see. It's odd how it was working, then
i rebooted and then poooof, nothing.

I'll have to get back on this tomorrow.



Ok well I've solved the problem.

I bought a new SD card, partitioned it, and all works well now!

I did fsck but it didn't much. Probably because I didn't know what to
do with it other than keep pressing yes to all of the messages.

Well, all is solved now. Thank you both.


I am glad tht worked for you, however I did not have time to go and
buy another card. I found in the kernel logs this

OMAP3: MMC needs CONFIG_REGULATOR{,_TWL4030} now in defconfigs

MMC doesn't work after 3fe326511c66ab842ef0a09a1f4c564b1a8beecf unless
CONFIG_REGULATOR, CONFIG_REGULATOR_TWL4030 are present in the .config.
Add those in for all OMAP3 defconfigs. Tested on BeagleBoard, but
this is
presumably needed for anything with MMC and TWL4030.

Signed-off-by: Paul Walmsley <>
Acked-by: David Brownell <>
Signed-off-by: Tony Lindgren <>

2 months agoRX51: connect VAUX3 to MMC2
commit | commitdiff | tree
Adrian Hunter [Tue, 24 Mar 2009 12:17:05 +0000]
RX51: connect VAUX3 to MMC2

Signed-off-by: Adrian Hunter <>
Signed-off-by: Tony Lindgren <>

2 months agoOMAP: mmc_twl4030 nicely disable vmmc_aux
commit | commitdiff | tree
Adrian Hunter [Tue, 24 Mar 2009 12:15:54 +0000]
OMAP: mmc_twl4030 nicely disable vmmc_aux

The MMC driver turns the power off before it turns it
on. To avoid regulator warnings, vmmc_aux must only be
disabled if it has previously been enabled.

Signed-off-by: Adrian Hunter <>
Acked-by: David Brownell <>
Signed-off-by: Tony Lindgren <>

So I did that and it works.
Look in drivers near the bottom of the list from menuconfig and select
Voltage and Current regulators.
And inside that select the TI TWL4030
Recompile and you should be good.