Bonescripts not running properly on webserver and Cloud9 IDE Jessie Snapshot (2014-11-19)

I just flashed the newest Jessie snapshot and I have not been able to successfully run the test scripts on the webserver.

Even when i run the blinkled.js example I get this error:

debugger listening on port 15454
error: Unable to find LED: usr0
error: Unable to find LED: usr1
error: Unable to find LED: usr2
error: Unable to find LED: usr3

if(typeof resp.err != ‘undefined’) {
TypeError: Cannot read property ‘err’ of undefined
at Object.f.pinMode (/usr/local/lib/node_modules/bonescript/index.js:161:19)
at Object. (/var/lib/cloud9/examples/blinkled.js:6:7)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Module.runMain [as _onTimeout] (module.js:497:10)
at Timer.listOnTimeout [as ontimeout] (timers.js:110:15)

[Process stopped]

retry with the v3.8.x based kernel:

sudo apt-get update
sudo apt-get install linux-image-3.8.13-bone68
sudo reboot


Is there a quick/dirty way I can get this to work on a 3.18 kernel?

OR, where can I start looking to port it (a driver I assume) to 3.18?

OR, is it the tunnel to madness and not to be entered?

It seems like the device names have changed so I did a little quick hacking on hw_oldkernel.js, which resulted in the GPIO’s being found but other errors generated. Rather than continue this, I’m going to step back and look at my options…

With the new device names, I can work on the GPIO’s through the cloud9 IDE. All I had to do is change the gpio sysfs string from “/sys/class/leds/beaglebone::” to “/sys/class/leds/beaglebone:green:” (hw_oldkernel.js) This works ONLY through the cloud9 browser IDE; when I run on a command line using sudo, the bonescript paths are not found and when I run as a normal user I get permission errors on the devices. Soooo, I guess the cloud9 IDE has superuser rights or something.

Overall it’s a pretty nice interface.