Booting Android on the BeagleBone Black not working?

I was able to put Android onto a microSD card (link here, not the TI link). However, when I attempted to boot it, it would not work, as the BBB would run the eMMC. When I tried to flash it onto the BeagleBone Black, none of the user LEDs were lighting up, so I don’t think that worked either. What can I do to fix this?

Does it help if you hold the button next to the microSD card slot down
before power on..


That's what I was doing before, but it hasn't worked.

Did you try the steps described here?


Not yet. I'll give it a shot.

One of my guys set that page up and got it running. And I have seen it running!


Sweet. Right now 7Zip is extracting the .img. Pretty cool the Windows
tutorial is already up since this file just came out yesterday.

Ooooh… a wiki! And a wiki for installing BeagleSNES, too!

I think that I’m going to rebuild that Android image again sometime soon. In fact, I want to rebuild the whole thing from scratch again to see if there was anything that I missed in my build instructions. On the next build, I want to use Robert’s default kernel (rather than my trimmed down BeagleSNES kernel) with the Android drivers and put that extra kernel command line in the uEnv.txt to get rid of the framebuffer cursor. I know that blinking cursor is probably driving someone nuts right about now. There are a lot of features that people might expecting that I compiled out of the kernel because BeagleSNES didn’t really need them…


It works! Thanks guys! Yeah, that blinking cursor is driving me
EXTREMELY nuts. Let me know when you create a new one without it. Any
estimated date?

I’m in the process of fetching all of the sources again to build it, so it might be as soon as tomorrow. But, I don’t know… depends how busy I am tomorrow. As for that blinking cursor, you can edit the uEnv.txt file in the boot partition to remove it. Just add this text:


… to the end of the line that has the “video=720x480-16@60” on it. Even if you are using Windows, the boot partition will mount on your PC (since it is a VFAT filesystem), so you should be able to edit it under Windows. Just put the microSD card into your PC the same way you did to copy the image onto it and it will show up as a new drive. The uEnv.txt will be in the root of that drive.



I have done the whole process of downloading, uncompressing, etc several times and I cannot get it to boot the android image! I am following the instructions at: and it is killing me. I am using the windows process as described to build the SD card image.

Any thoughts?

  • Eric


Any thoughts on what you did differently? I have done the whole process from downloading to building several times (7x) and I cannot seem to get my BBB to boot android. No user lights blink at all. It is like it doesn’t see the image. I am following the circuitco process at:!topic/beagleboard/ztFZ5iBIRfw

Gotten it to boot from the SD card before but that was to update the shipped OS.

  • Eric

Have you held the boot button down before and during you put in the power, and let it go once the user leds have been blinking?

Also, you are using the BeagleBone Black right?

Hey guys, I am having the same issue. I followed the following guide: to no avail. After creating the microSD card with the Android image by Andrew Henderson I placed it in the BBB and pressed and held the boot button before/during applying 5V power.

Nothing happens, no leds blink etc.

Removing the microSD card and booting normally, it will enter angstrom on the eMMC. Any ideas?

I’m assuming you have tried multiple times, correct? From my personal experience, it does take more than one try sometimes.
You may not be holding down long enough on the boot from SD button. If you hold it for 10 seconds without any LED’s it didn’t work.
My only suggestions are:

  • Unplug and re-plug everything. Power sourece, micro sd, USB hubs, display, power source. Make sure you power sources are 5V externals and are properly connected to a power outlet.
  • Be sure you are actually holding down the boot button; it can be pretty tough to press.
  • Try re-flashing your micro SD and make sure it is big enough (at least 4 GB)
  • Make sure you are using Win 32 Disk Imager ( )
  • Double check you have a good micro SD by booting from it using a different image (here are a few options )
  • Try multiple times. If it doesn’t work, remove power, eject micro SD, insert, micro SD, hold down boot button, apply power. It may take 2 or more attempts.

None of these things are guaranteed to work but definitely try them. As someone who hasn’t had this issue it is hard to speculate why it would not be working.

Yes, unfortunately i have tried your suggestions at least 7x. It is like the build is not right and not catching the boot.

Out of curiosity, I just tried the Android tutorial on circuitco and it worked fine on mine. Are you doing this off Linux or a Windows computer?

Yeah, I’m using a Windows computer too. Hmm…I wonder what can be wrong.

Hi! I currently managed to start the Android BeagleBone Black, but WHEN I connect the ethernet cable, the BBB switches off, no more leds, dead completely.
Any idea?