Booting from eMMC issue

Hello everyone,

I was happily tinkering with Beaglebone Blue until yesterday but now I cannot boot it from the eMMC. What I did was very simple. Trying out the lastest Debian image.

1- Downloaded the last Debian image (version 9.1). Using WinDisk32Imager I wrote the image to a 4 GB microSD card.
2- Inserted the microSD card and powered the Beaglebone Blue, while pressing the BOOT button, but just until LEDs start blinking. About 2 to 3 seconds pressing the button. I believe that nowadays it is not necessary to do this to boot from the microSD card.
3- It took some time but eventually it booted to the new OS.
Nothing more than the usual stuff.
4- Did nothing special with it. Just confirmed that it was the Debian 9.1 version I was running and not the one from emMC.
5- Shutted down BeagleBone Blue. It was very late so I did nothing else.

Next day I removed the microSD card, to continue with my experiences, but the Beaglebone Blue does not boot from the eMMC. It doesn’t even appear as a remote disk to the Operating System (Windows 7, by the way). All it does, after some LEDs action, is blink the USR0 LED, and with a pattern that resembles heart beat.

What has happened? Did the eMMC become corrupted in any way? For some reason some file was modified in a way that now I can only boot from a microSD card (some bug with the new Debian 9.1 release)? Something else?

Please advise.

Nope, shouldn't have affected anything..


Did you try to log in via cloud9 through , , or ? via micro-usb through Chad

Thank you for your reply,

Yes, I tried to connect like you say Chad, but nothing positive happens. All I get is “The connection has timed out” or “Server not found”.
I tried with putty but it goes nowhere.

Probably my only option will be to reflash the eMMC. But I would like to understand what has happened.
If that also fails, then I hope it continues to boot from a SD card.

As no one can give me a solution to the problem I will try to flash the eMMC.

As anyone tried to do that? Can I trust the instructions given in

I’ve done that with my Beaglebone Black but the procedure is a bit different.

It can be trusted. Does not matter whether one pushes RST (reset) button or plugs in power as long as SD card is in first and then SD button is held down and only after this power it up.
Make sure to use BBBL images (not BBB like I at first did ;-)) and be patient when botting, i.e. it will show a cylon effect after some time of heartbeat flashing. When finished all blue LEDs will be either fully on indicating error I guess (at least it was like this for me) or all will be 100% off ready to remove SD card and boot up.

Hi Nuno and everyone else,

We have recently come across this peculiar issue: The EMMC of the beaglebone blue just stopped booting up without an apparent reason. At the same time, we noticed erratic behavior by the BB during updates and/or downloads. In particular, the update hangs at random stages of the download and Ctrl-C is the only solution. However, after the interruption, the BB is not working properly (e.g, recurring hangs and in several cases errors in the file system ). Regardless, only hard reset works (i.e., issuing a reboot command will just hang the board again).

We initially though that the use of stretch was probably the cause for the issue, bit the same problem occurred with Debian Jessie SD card. We have re-written the Debian image multiple times and the same problem (i.e., the hangs during updates) re-occurs consistently at various stages of the update. It should be noted that the EMMC is still not bootable, but we haven’t attemped to re-flash it.

Looking forward to your help and comments



Hello George,

For the time being I cannot help you. First because I also don’t know what is happening. Second because after what has happened to my BBBL I didn’t tried to reflash the eMMC. I’m still doing some stuff with it, booting from the sdCard (and working fine, but I didn’t tried to update or upgrade so, don’t know if it fails or not at some point) and until I’m finished with doing that I will do nothing with the eMMC. When I do, then I’ll tell you what was the result: a bricked BBBL or success.

The more savvy guys could help us but or there is no one in the forum or they are not willing to help us.

My thoughts are: some software issues with Debian image; issue with the eMMC; issue with the electronics that choose from where to boot, something like a fried resistor, a chip or something like that.