booting problem with upgraded kernel

Hello everyone,

I am using an angstrom image to boot my BBxM rev B. its working fine
with kernel image 3.0.8+ i.e. its booting properly.but when i install
driver for UVCVIDEO i.e. "kernel-module-uvcvideo" my kernel image
upgrades to 3.0.23+ and on next reboot i am getting the following logs
stuck and not booting further.

3.829742] mmc0: new SDHC card at address 0002
[ 3.834960] mmcblk0: mmc0:0002 00000 3.70 GiB
[ 3.841857] mmcblk0: p1 p2
[ 3.952423] EXT3-fs: barriers not enabled
[ 3.958435] kjournald starting. Commit interval 5 seconds
[ 3.964294] EXT3-fs (mmcblk0p2): mounted filesystem with writeback
data mode
[ 3.971801] VFS: Mounted root (ext3 filesystem) readonly on device
[ 3.982757] devtmpfs: mounted
[ 3.985961] Freeing init memory: 228K
[ 4.040832] usb 1-2.1: new high speed USB device number 3 using
[ 4.166687] usb 1-2.1: New USB device found, idVendor=0424,
[ 4.173919] usb 1-2.1: New USB device strings: Mfr=0, Product=0,
[ 4.184906] smsc95xx v1.0.4
[ 4.269287] smsc95xx 1-2.1:1.0: eth0: register 'smsc95xx' at usb-
ehci-omap.0-2.1, smsc95xx USB 2.0 Ethernet, 2e:10:24:91:5e:01
[ 4.346893] systemd[1]: systemd 37 running in system mode. (+PAM

[ 34.390808] systemd[1]: /sbin/modprobe failed with error code 1.
[ 34.399444] systemd[1]: Set hostname to <beagleboard>.

and its not getting any further..i am stuck please help me out.

Subhadra Singh

Just a wild guess, but do you have a place for the 3.0.23 modules in the root file system? I think they should be under somewhere like /lib/modules/3.0.23/...



yes im having "/lib/modules/3.0.23/" inside it there are driver files
of .ko format for both uvcvideo and rtl8712. how this gonna help pls
tell me.

Have you run "depmod -a" to build module dependencies followed by a reboot?

Yes i tried this also but still same results. Not booting up.

yes i now tried depmod -a followed by reboot but still same
results,Not booting up. what should i do next?

ya i hav tried it but still the same thing Not booting,Same Message.
What next i should do?

yes i hav tried this but still same results Not Booting up. pl help