Bootup problems and communication problems

I just got a beagle board but I can't seem to send any data to it
through minicom in linux or hyperterminal in windows.

I know the cable is good because I can connect to my IMU with the same
ttyusb cable. The usb cable has a usbtoserial converter which goes to
the AT/Everex ( 10 pin connector ). My console is setup at 115200 8N1
with HW and SW flow control are both turned off.

I can see data coming out and I see the beagleboard splash screen on
my monitor but it won't accept/respond to any characters that I send

I have already partitioned a 2GB SD card and loaded Angstrom on it,
but it fails to read the boot string ( ** Unable to read "boot.scr"
from mmc 0:1 ** ) then after/while uncompressing linux is reports

No filesystem could mount root, tried: ext3
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-

I can't try to fix the problem because I can't type any commands to
the board.


It sounds like your serial connection is still not correct. Are you using a twist cable form your ribbon cable to the PC? I suggest you follow the procedure in the System Reference Manual to make sure everything is correct.