Bricked BBBlue??

Previously posted on SO:
…but this is probably a better venue:

My BBBlue appears to be bricked. Everything was fine, then I pressed the power button a few seconds, it shut down, and after that it won’t power up. Two blue Green LEDs come on with battery connect or 12 V power, but no blink, no battery state, etc. I’ve tried various combinations of battery, USB, and 12 V power, but I only get the 75% Battery LED, and the Green user LED. When I press the reset button, those LEDs go dim, but not off entirely.

3.3 V and 5.0 V rails are working.

Both Red User LED and 25% Battery LED have a short pulse about once per second.

I put the Red User LED on an oscope and this is what I see:

Red User LED again, with zoom:

And on the 25% LED…

The 25% LED does the above waveform interspersed with a boring 10 us pulse every second or so.

When I plug it into USB on Windows, the COM port shows up in Device Manager, but when I try opening up that port in Putty, it says it can’t connect. Anyway, even when it did boot, it took a while for the the COM port to be connectable, so I expect there is some software that needs to run for it to work (there is no FTDI chip + USB hub on the board). That said, I’m not sure how a COM port can appear on USB without the SoC booting up, unless that’s built into the SoC host capability hardware somehow.

The “removable drive” that normally appears doesn’t show up.

I tried putting in the SD card which I had previously used to flash the eMMC to the latest image, but no response there (I was expecting the LEDs to flash while the script copied the contents of the SD card to the eMMC).

What’s next? Is there a hard serial port on the board, not USB, so I can try to observe that? None of the connector pins had a UART or any other waveform on them whatsoever – just either 3.3, GND, or some version of an almost-alive pulse as in the waveforms.

Pressing any of the buttons, then power-cycle and release, with SD card in place, does not change anything.

It appears something is trying to boot up, but it can’t.
Is the PMIC in the SoC dead?
Or should I realize my time is valuable and just buy another one?