Bricked board! Completely erased NAND!

Hi everyone,

Can someone please direct me to a page describing how to unbrick a
beagle board?
I accidently erased all NAND and when I boot my board I get nothing
via the minicom!

Thank you,


You can't brick an omap3 board, since it has a bootrom that can use sd, nand and serial to boot a stepping stone. There is a whole page on the wiki about recovery and I suspect using plain old google will turn up pointers to that on the first result page.


might help -> try the script - it requires a serial
port and a miniusb (b type) cable.
Nishanth Menon

Hi thank you both for your responses.
might help -> try the script - it requires a serial
port and a miniusb (b type) cable.

I downloaded the file you linked to me and tried to run the but it just says

Usage: /home/hurdy/Desktop/beagle_recovery/beagle_recover/ ttyPort
Required - sudo permissions, beagleboard, 1 usb and 1 uart cable

how would I use this?
I've plugged my beagleboard into a USB port on my computer and I also
have the Serial COM on ttyUSB0.

Thank you.

Ah nevermind, I have it now! It works! Excellent thank you very very
much for the link to that file! I mutch appreciate your help.

Not that it matters now that you have it figured out, the actual steps
are simple:
1. first shutdown the board.
2. run 'sudo /dev/ttyUSB0' in a terminal -> you need
super user permissions(sudo permissions) to run this script.
3. Keep the pushbutton S1pressed while powering on the board -> there
are two white push button switches, use the one closer to the edge of
the board
NOTE: if your nand is completely erased, the above step wont be
needed, but what the heck, use it for preventing all kind of cases
where you have an MMC card/partly corrupted nand etc..
4. Once the terminal starts downloading, you can remove ur finger off
the S1 switch ;)..
5. wait a bit for files to reach and be flashed :).. the script should
exit happily once it is done.

NOTE1: the version of x-loader and u-boot in the tarball is probably
old, you may want to replace the files from u-boot once it is up and
NOTE2: I put a prebuild x32 ubuntu 8.10 binary out there, if you have
x64 bit or fedora or something else, and want to build the apps
yourself, feel free to download and build code from [1]

Nishanth Menon
(TODO: Still planning on putting together a video showing the
process.... gah... i keep forgetting.. any taker for the same, please
go ahead)..
- the video i have there currently sucks and has reported to create
nausea in few folks :(..

Hi guys,

I doubt any of you still check this thread, but on the off chance you do, does anyone have a copy of whatever used to be on the page at
I have similarly messed up my board, and it seems most helpful pages are no longer existent.


  • Catherine

Your link gives me an error. None of the boards have NAND per se. The either have eMMC (BeagleBone Black) or an SD card.

Which board do you have?


Yeah, I get an error from the link as well. It was posted to this thread a while ago, and I was hoping to find what it used to link to. I am using a BeagleBoard Rev D. I was trying to set it up to boot Ubuntu from an SD when I messed it up, and now when I run a serial connection I just get garbage.

Thanks for your help!

  • Catherine