Building kernel for Beagleboard-C4


I tried to build image for my Beagleboard-C4 using the recent version of Angstrom and Yoctoproject/Poky, but got the following problem:
I compiled all kernels I found compatible with my board: 3.2, 3.3, 3.4, 3.7, 3.8, 3.14, including mainline and ti-staging, but none of them running on my board. The result is the same for all:

--------------- 8< -------------------
Loading file "/boot/uImage" from mmc device 0:2 (xxa2)
3394824 bytes read
Booting from mmc ...
## Booting kernel from Legacy Image at 80200000 ...
    Image Name: Linux-3.3.7
    Image Type: ARM Linux Kernel Image (uncompressed)
    Data Size: 3394760 Bytes = 3.2 MiB
    Load Address: 80008000
    Entry Point: 80008000
    Verifying Checksum ... OK
    Loading Kernel Image ... OK

Starting kernel ...

Uncompressing Linux... done, booting the kernel.
--------------- 8< -------------------

No more output, heartbeat LED is not blinking.

Except the version 3.14.25: it runs perfectly, but I could not compile the package omap3-sgx-modules because it seems incompatible with this kernel (4.05, 4.09, 5.01 versions). I can compile it with older kernels (using the 4.09 version) but they do not run at all.

How can I build a working kernel+omap3-sgx-modules? Some years ago it worked for me.

Thanx in advance
Gyorgy Kovesdi

If you're still using uImage, your u-boot is too old, please use the matching u-boot found in $DEPLOY_DIR