Building with the Linux Kernel, U-boot, and Debian Minimal...


I seem to be in a pickle. Um…here are some commands:

git clone
cd linux
git checkout 5.10
wget some-toolchain or sudo apt install arm-linux-gnueabihf
export ARCH=arm
export CROSS_COMPILE=arm-linux-gnueabihf-
make omap2plus_defconfig
make menuconfig

is arm-linux-gnueabihf for Buster older while the CROSS_COMPILE command needs an updated versioning of the arm-linux-gnueabihf install for Bullseye?

Here is where things get iffy.

  1. Would I need to put the MLO and u-boot-dtb.img in a boot partition along w/ a filesystem in a rootfs.
  2. Would the rootfs need zImage or any other amount of data stored in it?

I think I am stuck listening to commands and tutorials outside of what actually works for me and my set up.


P.S. If you see where I may be making mistakes, please let me know.

Just for reference:

  1. I have made a boot partition and rootfs partition many times but w/ the beaglebone-green-gateway, I have been unsuccessful thus far.
  2. I will try w/ a BBB or BBBW to see if the root cause is the board in question or my set up.

In the meantime, please let me know what you think of the commands from that I accumulated from this link: Using Device Tree Overlays, example on BeagleBone Cape add-on boards – Blog


I was using some commands from Debian: Getting Started with the BeagleBone Black - Linux Guides - Engineering and Component Solution Forum - TechForum │ Digi-Key which seem very updated. Nice work and good on ya.

But…I am seeing that this is becoming time consuming w/out much work being successful for now. Please advise.

You can just use

sudo apt install gcc-arm-linux-gnueabihf
make zImage modules dtbs


1 Like

Hello Sir,

@RobertCNelson …it seems that everything compiles correctly. zImage, dtbo, and dtb files all compile along with the overlays.

I think the issue is getting up and running on a BBB with the configurations available currently.

I tried this command:

  1. sudo mkfs.vfat -F 32 -n boot /dev/mmcblk0p1
    a. My /dev/ dir. does not have such a file, i.e. mmcblk anything.
    b. I cannot just make up the file for whatever reason.
  2. I also tried sudo mkfs.vfat -F 32 -n boot /dev/sdb1
    a. This works but does not boot into u-boot.

Anyway, even w/ ARCH=arm CROSS_COMPILE=arm-linux-gnueabihf- all the commands fathomable, I get no u-boot output on boot and this is whether or not I apply the S2 button.

I know on the first boot, u-boot takes a bit of time depending on what is exactly on the system.

I waited.


P.S. There is a person in GSoC this year (I think) and I was going to pitch in to assist but even my current understandings are a bit dated (I think). If this makes sense, okay. Please send some type of reply when you get around to it.

Hi @silver2row see the directions here, for partition layout, etc.


1 Like