Can ping but cannot get any web

I am testing a new (to me) cape on Beaglebone Black which worked for two days. The image is run on SDCARD. Suddenly I could not access the web on the image and cannot SSH, no loss of IP connectivity. I can ping, I removed the SD card and reset the BBB but same issues. I connected via USB and was able to access the web and SSH through the RNDIS setup. Any ideas why I can ping but cannot do anything else? How would I determine if hardware or software?

Sounds like software. Can you get DNS resolution? That’s the first thing I’d check.

I DNS resolution is intermittent, I have been using all IP address and no luck. I assumed it was the SDcard image so did a new one and no change. Tried to just ssh to the original BBB image and no luck either. My last thing is to reflash eMMC but worried it's hardware!

You can ping an Internet address, (e.g. or you mean pinging one
of your local addresses (e.g. If it is the latter, then of
course, you will not necessarily be able to connect to the Internet. The
computer you are connected to must have Internet Connection Sharing
enabled (I am guessing it is a Windows Computer ...)